aboutsummaryrefslogtreecommitdiffstats
path: root/community/cpptest
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2018-03-29 18:23:19 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2018-03-29 18:23:19 +0000
commit1fe4ff55f34098d4cf756ab6c6065dabb41bb2a1 (patch)
tree2747885861c4feac22e8934639338ba53b8f5961 /community/cpptest
parent75588174d69a68283103f63671ce3b478592d96b (diff)
downloadaports-1fe4ff55f34098d4cf756ab6c6065dabb41bb2a1.tar.bz2
aports-1fe4ff55f34098d4cf756ab6c6065dabb41bb2a1.tar.xz
testing/cpptest: move to community
Diffstat (limited to 'community/cpptest')
-rw-r--r--community/cpptest/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/community/cpptest/APKBUILD b/community/cpptest/APKBUILD
new file mode 100644
index 0000000000..cfbd709857
--- /dev/null
+++ b/community/cpptest/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Roberto Oliveira <robertoguimaraes8@gmail.com>
+# Maintainer: Roberto Oliveira <robertoguimaraes8@gmail.com>
+pkgname=cpptest
+pkgver=1.1.2
+pkgrel=0
+pkgdesc="Portable and powerful unit testing framework for handling automated tests in C++"
+url="http://cpptest.sourceforge.net/"
+arch="all"
+license="LGPL"
+subpackages="$pkgname-dev"
+source="https://sourceforge.net/projects/cpptest/files/cpptest/cpptest-1.1.2/cpptest-1.1.2.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ default_prepare
+ update_config_guess
+}
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make install DESTDIR="$pkgdir"
+}
+
+sha512sums="da1030c69a5886e752b9ae08b65c501334c7d2d4abd2174190209ce11ed351239a615b9f7c5019ee601289523b2c21a1205d2042e59aea6c2882d77d636fc57a cpptest-1.1.2.tar.gz"