aboutsummaryrefslogtreecommitdiffstats
path: root/community/dash
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-10-31 23:32:06 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-10-31 23:32:51 +0100
commit238c1775cc0e86b38aeddd6cf8656260999278e7 (patch)
treec3ff87460f91912e296a8e0a0e0f6398481fda49 /community/dash
parent5f190354a00c258422e6df011e37decbdf1ff510 (diff)
downloadaports-238c1775cc0e86b38aeddd6cf8656260999278e7.tar.bz2
aports-238c1775cc0e86b38aeddd6cf8656260999278e7.tar.xz
community/dash: move from testing
Diffstat (limited to 'community/dash')
-rw-r--r--community/dash/APKBUILD41
-rw-r--r--community/dash/dash.post-install3
l---------community/dash/dash.post-upgrade1
-rw-r--r--community/dash/dash.pre-deinstall3
4 files changed, 48 insertions, 0 deletions
diff --git a/community/dash/APKBUILD b/community/dash/APKBUILD
new file mode 100644
index 0000000000..3e855de699
--- /dev/null
+++ b/community/dash/APKBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=dash
+pkgver=0.5.9.1
+pkgrel=0
+pkgdesc="Small and fast POSIX-compliant shell"
+url="http://gondor.apana.org.au/~herbert/dash/"
+arch="all"
+license="GPLv2+"
+# needs 'nl' utility from coreutils
+makedepends="coreutils"
+install="$pkgname.post-install $pkgname.post-upgrade $pkgname.pre-deinstall"
+subpackages="$pkgname-doc"
+source="http://gondor.apana.org.au/~herbert/$pkgname/files/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+
+ ./src/dash -c 'echo ok'
+}
+
+package() {
+ cd "$builddir"
+
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="d56a043b8fab4693d3f70cceb531c37174e7ded4acd5549e53048d7ce29125ff21d7e758f51a4a73e06250d051e246467039989275838c19a2579edea3f72b7d dash-0.5.9.1.tar.gz"
diff --git a/community/dash/dash.post-install b/community/dash/dash.post-install
new file mode 100644
index 0000000000..69af64bb04
--- /dev/null
+++ b/community/dash/dash.post-install
@@ -0,0 +1,3 @@
+#!/bin/sh
+add-shell '/bin/dash'
+exit 0
diff --git a/community/dash/dash.post-upgrade b/community/dash/dash.post-upgrade
new file mode 120000
index 0000000000..3514e3b3c1
--- /dev/null
+++ b/community/dash/dash.post-upgrade
@@ -0,0 +1 @@
+dash.post-install \ No newline at end of file
diff --git a/community/dash/dash.pre-deinstall b/community/dash/dash.pre-deinstall
new file mode 100644
index 0000000000..07f1c9d348
--- /dev/null
+++ b/community/dash/dash.pre-deinstall
@@ -0,0 +1,3 @@
+#!/bin/sh
+remove-shell '/bin/dash'
+exit 0