aboutsummaryrefslogtreecommitdiffstats
path: root/community/drawterm
diff options
context:
space:
mode:
authorBreno Leitao <breno.leitao@gmail.com>2017-04-10 12:23:02 +0000
committerBreno Leitao <breno.leitao@gmail.com>2017-04-10 12:23:02 +0000
commit2f927205bf030b49bf71a3c1fcc7ed8715d2626a (patch)
tree6c94794276f5ab96a9fa30f9f211747b9ce7fe34 /community/drawterm
parent5a585689d7009bb24ed72b6522c65b7476ba7cf8 (diff)
downloadaports-2f927205bf030b49bf71a3c1fcc7ed8715d2626a.tar.bz2
aports-2f927205bf030b49bf71a3c1fcc7ed8715d2626a.tar.xz
community/drawterm: Fix build on ppc64le
Currently drawterm fails to build because it is looking for powerpc specific files in a different directory. Setting it to the proper place.
Diffstat (limited to 'community/drawterm')
-rw-r--r--community/drawterm/APKBUILD10
1 files changed, 10 insertions, 0 deletions
diff --git a/community/drawterm/APKBUILD b/community/drawterm/APKBUILD
index 9e59c11810..f12e393f8f 100644
--- a/community/drawterm/APKBUILD
+++ b/community/drawterm/APKBUILD
@@ -20,6 +20,16 @@ _srcurl="https://code.9front.org/hg/$pkgname"
_srcrev="169f32a871c9"
builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$builddir"
+
+ if [ "$CARCH" = "ppc64le" ]; then
+ ln -s posix-power posix-ppc64le
+ fi
+ default_prepare
+}
+
snapshot() {
mkdir -p "$srcdir" && cd "$srcdir"