aboutsummaryrefslogtreecommitdiffstats
path: root/community/dynamips
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-12-21 10:51:43 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-12-21 10:52:03 +0000
commit5719ca1c71846b5215491d85d488bdbd5c219694 (patch)
treee27512bacad547fd6f25e3768cd579fc46eb053b /community/dynamips
parent8518d438784e88f6207837d21fd22c8de3840bf6 (diff)
downloadaports-5719ca1c71846b5215491d85d488bdbd5c219694.tar.bz2
aports-5719ca1c71846b5215491d85d488bdbd5c219694.tar.xz
community/dynamips: removed unused makedepends, APKBUILD cleanup
Diffstat (limited to 'community/dynamips')
-rw-r--r--community/dynamips/APKBUILD26
1 files changed, 8 insertions, 18 deletions
diff --git a/community/dynamips/APKBUILD b/community/dynamips/APKBUILD
index 0de3f72343..7e86321853 100644
--- a/community/dynamips/APKBUILD
+++ b/community/dynamips/APKBUILD
@@ -2,38 +2,28 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=dynamips
pkgver=0.2.16
-pkgrel=0
+pkgrel=1
pkgdesc="Cisco router emulator"
url="https://github.com/GNS3/dynamips"
arch="all"
license="GPL2"
-depends=""
-depends_dev=""
-makedepends="$depends_dev cmake libpcap-dev libelf-dev linux-headers util-linux-dev"
-install=""
+makedepends="cmake libpcap-dev libelf-dev linux-headers"
subpackages="$pkgname-doc"
source="${pkgname}-${pkgver}.tar.gz::https://github.com/GNS3/${pkgname}/archive/v${pkgver}.tar.gz"
-_builddir="$srcdir"/$pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir"/$pkgname-$pkgver
build() {
- cd "$_builddir"
+ cd "$builddir"
if test $CARCH == x86_64; then
export DYNAMIPS_ARCH=amd64
fi
- cmake ./ -DCMAKE_INSTALL_PREFIX:PATH=/usr
+ export CFLAGS="$CFLAGS -Wno-enum-compare"
+ export CXXFLAGS="$CXXFLAGS -Wno-enum-compare"
+ cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR=${pkgdir} install
}