aboutsummaryrefslogtreecommitdiffstats
path: root/community/easypki
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2017-10-02 17:42:13 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2017-10-02 17:42:18 +0200
commitb4cde20c32a37e400dcda159f956c0e69a7ff0ed (patch)
tree741e3816e3c8e8e4a1178f7b42da5aad55dd45ab /community/easypki
parenta7ad49f1a8b55dddc397c89f98284d90363984b6 (diff)
downloadaports-b4cde20c32a37e400dcda159f956c0e69a7ff0ed.tar.bz2
aports-b4cde20c32a37e400dcda159f956c0e69a7ff0ed.tar.xz
testing/easypki: move from community and enable check
Diffstat (limited to 'community/easypki')
-rw-r--r--community/easypki/APKBUILD54
-rw-r--r--community/easypki/glide.lock20
-rw-r--r--community/easypki/glide.yaml10
-rw-r--r--community/easypki/overide-version.patch11
4 files changed, 95 insertions, 0 deletions
diff --git a/community/easypki/APKBUILD b/community/easypki/APKBUILD
new file mode 100644
index 0000000000..fa0f815dfb
--- /dev/null
+++ b/community/easypki/APKBUILD
@@ -0,0 +1,54 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
+pkgname=easypki
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="Creating a certificate authority the easy way"
+url="https://github.com/google/easypki"
+arch="all"
+license="Apache-2.0"
+depends=""
+makedepends="glide go"
+install=""
+subpackages=""
+source="easypki-$pkgver.tar.gz::https://github.com/google/easypki/archive/v$pkgver.tar.gz
+ glide.lock
+ glide.yaml
+ overide-version.patch
+ "
+builddir="$srcdir/easypki-$pkgver"
+
+build() {
+ export GOPATH="$startdir"
+ cd "$builddir"
+ cp "$srcdir"/glide.yaml "$srcdir"/glide.lock .
+ glide install --skip-test
+ go build -v -ldflags "-s -w" \
+ -o "$builddir"/easypki ./cmd/easypki
+}
+
+package() {
+ cd "$builddir"
+ install -Dm755 easypki "$pkgdir"/usr/bin/easypki
+}
+
+check() {
+ "$builddir"/easypki --help > /dev/null
+}
+
+glide_init() {
+ abuild clean deps unpack prepare
+ cd "$builddir"
+ export GOPATH="$startdir"
+ rm -f glide.yaml glide.lock
+ glide init --non-interactive
+ glide update
+ cp glide.yaml glide.lock "$startdir"
+ cd "$startdir" && abuild checksum clean
+}
+
+
+sha512sums="733a61645be46d1437b94e31d537c29b6648e2ff805abfba039154c4e765262c60652cdb42df44c17ae1553794cb667515cb03e4c9dfbfab42f9000f876012ca easypki-1.1.0.tar.gz
+34e994dd626c832cb8794bc08617096398782c9242beee2f74c691eec41cebd3db56cbc765094bb571e9934bfef0c4593b6bd8095683be1f74ab992b47ed0476 glide.lock
+c0e0ddd4c608d0a76a8a964a985202a2b8a70a38ca274f1e0714ec22cae5e26d064809b70983ec64805ef558afc9aca9ddb00c24d13f33842c6aedf48b45508b glide.yaml
+bfe4802694b7921a2a015900d56356dfda0e04a153c2b22c3bc03899c4e60fc2d79a425982f8dbdf08cee4fda0e793687f55c549e1ef657b4ef366705a2b9826 overide-version.patch"
diff --git a/community/easypki/glide.lock b/community/easypki/glide.lock
new file mode 100644
index 0000000000..7d591adc6e
--- /dev/null
+++ b/community/easypki/glide.lock
@@ -0,0 +1,20 @@
+hash: cd94c9a799f223790b2ec67c64a31c165b576179fb83194de2fd0829f8366b92
+updated: 2017-05-09T11:05:34.140243958+02:00
+imports:
+- name: github.com/boltdb/bolt
+ version: 5cc10bbbc5c141029940133bb33c9e969512a698
+- name: github.com/codegangsta/cli
+ version: d70f47eeca3afd795160003bc6e28b001d60c67c
+- name: github.com/go-yaml/yaml
+ version: cd8b52f8269e0feb286dfeef29f8fe4d5b397e0b
+- name: github.com/google/easypki
+ version: d7ae2721b8268b1e2880656504f41d4ae94c902b
+ subpackages:
+ - pkg/certificate
+ - pkg/easypki
+ - pkg/store
+- name: golang.org/x/sys
+ version: 8f0908ab3b2457e2e15403d3697c9ef5cb4b57a9
+ subpackages:
+ - unix
+testImports: []
diff --git a/community/easypki/glide.yaml b/community/easypki/glide.yaml
new file mode 100644
index 0000000000..785d15a234
--- /dev/null
+++ b/community/easypki/glide.yaml
@@ -0,0 +1,10 @@
+package: easypki-1.1.0
+import:
+- package: github.com/boltdb/bolt
+- package: github.com/codegangsta/cli
+- package: github.com/go-yaml/yaml
+- package: github.com/google/easypki
+ subpackages:
+ - pkg/certificate
+ - pkg/easypki
+ - pkg/store
diff --git a/community/easypki/overide-version.patch b/community/easypki/overide-version.patch
new file mode 100644
index 0000000000..7ae8e5c60a
--- /dev/null
+++ b/community/easypki/overide-version.patch
@@ -0,0 +1,11 @@
+--- ./cmd/easypki/main.go.orig
++++ ./cmd/easypki/main.go
+@@ -158,7 +158,7 @@
+ app.Usage = "Manage pki"
+ app.Author = "Jeremy Clerc"
+ app.Email = "jeremy@clerc.io"
+- app.Version = "1.0.0"
++ app.Version = "1.1.0"
+
+ caNameFlag := cli.StringFlag{
+ Name: "ca-name",