aboutsummaryrefslogtreecommitdiffstats
path: root/community/evince
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-11-18 08:02:49 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-11-18 08:04:54 +0000
commit7fcb82f1afc8133bfe89982d00c597d7832ac19e (patch)
treedc38cd5e86e14e75c2cf60186863aa00f5a65371 /community/evince
parent29ca6f53f080234f321c67df7ec9706cd57933e1 (diff)
downloadaports-7fcb82f1afc8133bfe89982d00c597d7832ac19e.tar.bz2
aports-7fcb82f1afc8133bfe89982d00c597d7832ac19e.tar.xz
community/evince: move from main
Diffstat (limited to 'community/evince')
-rw-r--r--community/evince/APKBUILD68
1 files changed, 68 insertions, 0 deletions
diff --git a/community/evince/APKBUILD b/community/evince/APKBUILD
new file mode 100644
index 0000000000..fe3198208d
--- /dev/null
+++ b/community/evince/APKBUILD
@@ -0,0 +1,68 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=evince
+pkgver=3.18.2
+pkgrel=0
+pkgdesc="simple document viewer for GTK+"
+url="http://projects.gnome.org/evince/"
+arch="all"
+license="GPL"
+depends="adwaita-icon-theme"
+depends_dev="gtk+3.0-dev poppler-dev libsm-dev libevent-dev libxrandr-dev
+ libx11-dev libxcursor-dev libxcomposite-dev libxi-dev util-linux-dev
+ tiff-dev gobject-introspection-dev"
+makedepends="$depends_dev intltool itstool gnome-doc-utils
+ adwaita-icon-theme-dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang $pkgname-libs"
+source="http://ftp.gnome.org/pub/GNOME/sources/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.xz
+ "
+
+_builddir="${srcdir}/${pkgname}-${pkgver}"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --disable-nautilus \
+ --without-keyring \
+ --enable-introspection \
+ --disable-static \
+ --enable-comics \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+libs() {
+ default_libs
+ mv "$pkgdir"/usr/lib/* "$subpkgdir"/usr/lib/
+}
+
+doc() {
+ default_doc
+ if [ -d "$pkgdir"/usr/share/help ]; then
+ mv "$pkgdir"/usr/share/help "$subpkgdir"/usr/share/
+ fi
+}
+
+
+md5sums="c39af6b8b1c44d4393ef8ac9dab99c0b evince-3.18.2.tar.xz"
+sha256sums="42ad6c7354d881a9ecab136ea84ff867acb942605bcfac48b6c12e1c2d8ecb17 evince-3.18.2.tar.xz"
+sha512sums="9d73d23de18f89034bf3ba1f18aba37316ddd6304370f3442a39c62d95a3443a51b1b7c641616f7b2d2d4deb316f0ea5246650eee3e4458a2356c9f2b2406fe6 evince-3.18.2.tar.xz"