aboutsummaryrefslogtreecommitdiffstats
path: root/community/evince
diff options
context:
space:
mode:
authortmpfile <tmpfile@users.noreply.github.com>2017-05-13 13:24:40 -0300
committerShiz <hi@shiz.me>2017-05-14 03:35:55 +0200
commite2052758e0e6a071fa8b6eda5f5aeea6b0425c9c (patch)
tree9432f75bddb43e88ddd95962f6e599b35bafae77 /community/evince
parent68c73099447753d9ac19ebe2ad76eff4bbce18c9 (diff)
downloadaports-e2052758e0e6a071fa8b6eda5f5aeea6b0425c9c.tar.bz2
aports-e2052758e0e6a071fa8b6eda5f5aeea6b0425c9c.tar.xz
community/evince: modernize abuild
Diffstat (limited to 'community/evince')
-rw-r--r--community/evince/APKBUILD26
1 files changed, 7 insertions, 19 deletions
diff --git a/community/evince/APKBUILD b/community/evince/APKBUILD
index 14256492a4..37825e6fe3 100644
--- a/community/evince/APKBUILD
+++ b/community/evince/APKBUILD
@@ -13,24 +13,13 @@ depends_dev="gtk+3.0-dev poppler-dev libsm-dev libevent-dev libxrandr-dev
tiff-dev gobject-introspection-dev libxml2-dev"
makedepends="$depends_dev intltool itstool gnome-doc-utils
adwaita-icon-theme-dev"
-install=""
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang $pkgname-libs"
-source="http://ftp.gnome.org/pub/GNOME/sources/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.xz
- "
+source="http://ftp.gnome.org/pub/GNOME/sources/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.xz"
-_builddir="${srcdir}/${pkgname}-${pkgver}"
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="${srcdir}/${pkgname}-${pkgver}"
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -40,14 +29,13 @@ build() {
--without-keyring \
--enable-introspection \
--disable-static \
- --enable-comics \
- || return 1
- make || return 1
+ --enable-comics
+ make
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
}
libs() {