aboutsummaryrefslogtreecommitdiffstats
path: root/community/ftgl
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-08-26 07:41:51 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-08-26 07:42:22 +0000
commit4a2a6ce1a143e0983ca0d6ca754a2e0702504ca5 (patch)
treefd880a0cb962d03ca09ac6d08b7c4e54470c886c /community/ftgl
parent88c13e4e602acdfb860b84b289316cc0be213fb7 (diff)
downloadaports-4a2a6ce1a143e0983ca0d6ca754a2e0702504ca5.tar.bz2
aports-4a2a6ce1a143e0983ca0d6ca754a2e0702504ca5.tar.xz
community/ftgl: moved from unmaintaned
Diffstat (limited to 'community/ftgl')
-rw-r--r--community/ftgl/APKBUILD36
-rw-r--r--community/ftgl/ftgl-2.1.3-rc5-ldflags.patch118
-rw-r--r--community/ftgl/ftgl-2.1.3-rc5-ttf_font.patch12
3 files changed, 166 insertions, 0 deletions
diff --git a/community/ftgl/APKBUILD b/community/ftgl/APKBUILD
new file mode 100644
index 0000000000..7a859a1861
--- /dev/null
+++ b/community/ftgl/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=ftgl
+pkgver=2.1.3_rc5
+_pkgver=2.1.3-rc5
+pkgrel=4
+pkgdesc="freetype OpenGL layer"
+url="http://ftgl.wiki.sourceforge.net/"
+arch="all"
+license="GPL"
+depends=
+depends_dev="mesa-dev freetype-dev freeglut-dev bash"
+makedepends="$depends_dev
+ autoconf automake libtool"
+install=
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-${_pkgver}.tar.bz2
+ ftgl-2.1.3-rc5-ldflags.patch
+ ftgl-2.1.3-rc5-ttf_font.patch
+ "
+builddir="$srcdir/$pkgname-2.1.3~rc5"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --prefix=/usr || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+md5sums="c7879018cde844059495b3029b0b6503 ftgl-2.1.3-rc5.tar.bz2
+4432b8cda8622fea6608e061289dde22 ftgl-2.1.3-rc5-ldflags.patch
+7fc76e66ac2f6f91d04190417f001031 ftgl-2.1.3-rc5-ttf_font.patch"
diff --git a/community/ftgl/ftgl-2.1.3-rc5-ldflags.patch b/community/ftgl/ftgl-2.1.3-rc5-ldflags.patch
new file mode 100644
index 0000000000..be9331d6f5
--- /dev/null
+++ b/community/ftgl/ftgl-2.1.3-rc5-ldflags.patch
@@ -0,0 +1,118 @@
+diff -up ftgl-2.1.3~rc5/demo/Makefile.am.ldflags ftgl-2.1.3~rc5/demo/Makefile.am
+--- ftgl-2.1.3~rc5/demo/Makefile.am.ldflags 2008-06-02 03:10:10.000000000 +0200
++++ ftgl-2.1.3~rc5/demo/Makefile.am 2010-02-14 15:02:19.670081290 +0100
+@@ -9,14 +9,14 @@ simple_SOURCES = \
+ simple.cpp \
+ $(NULL)
+ simple_CXXFLAGS = $(FT2_CFLAGS) $(GL_CFLAGS)
+-simple_LDFLAGS = $(FT2_LIBS) $(GLUT_LIBS)
++simple_LDFLAGS = $(FT2_LIBS) $(GLUT_LIBS) $(GL_LIBS)
+ simple_LDADD = ../src/libftgl.la
+
+ c_demo_SOURCES = \
+ c-demo.c \
+ $(NULL)
+ c_demo_CFLAGS = $(FT2_CFLAGS) $(GL_CFLAGS)
+-c_demo_LDFLAGS = $(FT2_LIBS) $(GLUT_LIBS)
++c_demo_LDFLAGS = $(FT2_LIBS) $(GLUT_LIBS) $(GLUT_LIBS) -lm
+ c_demo_LDADD = ../src/libftgl.la
+
+ FTGLDemo_SOURCES = \
+@@ -27,7 +27,7 @@ FTGLDemo_SOURCES = \
+ trackball.h \
+ $(NULL)
+ FTGLDemo_CXXFLAGS = $(FT2_CFLAGS) $(GL_CFLAGS)
+-FTGLDemo_LDFLAGS = $(FT2_LIBS) $(GLUT_LIBS)
++FTGLDemo_LDFLAGS = $(FT2_LIBS) $(GLUT_LIBS) $(GL_LIBS)
+ FTGLDemo_LDADD = ../src/libftgl.la
+
+ FTGLMFontDemo_SOURCES = \
+@@ -38,7 +38,7 @@ FTGLMFontDemo_SOURCES = \
+ trackball.h \
+ $(NULL)
+ FTGLMFontDemo_CXXFLAGS = $(FT2_CFLAGS) $(GL_CFLAGS)
+-FTGLMFontDemo_LDFLAGS = $(FT2_LIBS) $(GLUT_LIBS)
++FTGLMFontDemo_LDFLAGS = $(FT2_LIBS) $(GLUT_LIBS) $(GL_LIBS)
+ FTGLMFontDemo_LDADD = ../src/libftgl.la
+
+ NULL =
+diff -up ftgl-2.1.3~rc5/demo/Makefile.in.ldflags ftgl-2.1.3~rc5/demo/Makefile.in
+--- ftgl-2.1.3~rc5/demo/Makefile.in.ldflags 2008-06-12 16:33:01.000000000 +0200
++++ ftgl-2.1.3~rc5/demo/Makefile.in 2010-02-14 15:02:01.866831398 +0100
+@@ -242,14 +242,14 @@ simple_SOURCES = \
+ $(NULL)
+
+ simple_CXXFLAGS = $(FT2_CFLAGS) $(GL_CFLAGS)
+-simple_LDFLAGS = $(FT2_LIBS) $(GLUT_LIBS)
++simple_LDFLAGS = $(FT2_LIBS) $(GLUT_LIBS) $(GL_LIBS)
+ simple_LDADD = ../src/libftgl.la
+ c_demo_SOURCES = \
+ c-demo.c \
+ $(NULL)
+
+ c_demo_CFLAGS = $(FT2_CFLAGS) $(GL_CFLAGS)
+-c_demo_LDFLAGS = $(FT2_LIBS) $(GLUT_LIBS)
++c_demo_LDFLAGS = $(FT2_LIBS) $(GLUT_LIBS) $(GL_LIBS) -lm
+ c_demo_LDADD = ../src/libftgl.la
+ FTGLDemo_SOURCES = \
+ FTGLDemo.cpp \
+@@ -260,7 +260,7 @@ FTGLDemo_SOURCES = \
+ $(NULL)
+
+ FTGLDemo_CXXFLAGS = $(FT2_CFLAGS) $(GL_CFLAGS)
+-FTGLDemo_LDFLAGS = $(FT2_LIBS) $(GLUT_LIBS)
++FTGLDemo_LDFLAGS = $(FT2_LIBS) $(GLUT_LIBS) $(GL_LIBS)
+ FTGLDemo_LDADD = ../src/libftgl.la
+ FTGLMFontDemo_SOURCES = \
+ FTGLMFontDemo.cpp \
+@@ -271,7 +271,7 @@ FTGLMFontDemo_SOURCES = \
+ $(NULL)
+
+ FTGLMFontDemo_CXXFLAGS = $(FT2_CFLAGS) $(GL_CFLAGS)
+-FTGLMFontDemo_LDFLAGS = $(FT2_LIBS) $(GLUT_LIBS)
++FTGLMFontDemo_LDFLAGS = $(FT2_LIBS) $(GLUT_LIBS) $(GL_LIBS)
+ FTGLMFontDemo_LDADD = ../src/libftgl.la
+ NULL =
+ all: all-am
+diff -up ftgl-2.1.3~rc5/test/Makefile.am.ldflags ftgl-2.1.3~rc5/test/Makefile.am
+--- ftgl-2.1.3~rc5/test/Makefile.am.ldflags 2010-02-14 14:43:14.819077822 +0100
++++ ftgl-2.1.3~rc5/test/Makefile.am 2010-02-14 14:43:49.227081230 +0100
+@@ -51,7 +51,7 @@ AM_CPPFLAGS = \
+ $(NULL)
+
+ CXXTest_CXXFLAGS = $(FT2_CFLAGS) $(GL_CFLAGS)
+-CXXTest_LDFLAGS = $(FT2_LIBS) $(GLUT_LIBS) -lcppunit
++CXXTest_LDFLAGS = $(FT2_LIBS) $(GLUT_LIBS) $(GL_LIBS) -lcppunit
+ CXXTest_LDADD = ../src/libftgl.la
+
+ CTest_SOURCES = \
+@@ -64,7 +64,7 @@ CTest_CPPFLAGS = \
+ -I$(top_srcdir)/src/FTFont \
+ -I$(top_srcdir)/src/FTLayout
+ CTest_CFLAGS = $(FT2_CFLAGS) $(GL_CFLAGS)
+-CTest_LDFLAGS = $(FT2_LIBS) $(GLUT_LIBS)
++CTest_LDFLAGS = $(FT2_LIBS) $(GLUT_LIBS) $(GL_LIBS)
+ CTest_LDADD = ../src/libftgl.la
+
+ NULL =
+diff -up ftgl-2.1.3~rc5/test/Makefile.in.ldflags ftgl-2.1.3~rc5/test/Makefile.in
+--- ftgl-2.1.3~rc5/test/Makefile.in.ldflags 2010-02-14 14:43:20.365077958 +0100
++++ ftgl-2.1.3~rc5/test/Makefile.in 2010-02-14 14:44:13.653078013 +0100
+@@ -294,7 +294,7 @@ AM_CPPFLAGS = \
+ $(NULL)
+
+ CXXTest_CXXFLAGS = $(FT2_CFLAGS) $(GL_CFLAGS)
+-CXXTest_LDFLAGS = $(FT2_LIBS) $(GLUT_LIBS) -lcppunit
++CXXTest_LDFLAGS = $(FT2_LIBS) $(GLUT_LIBS) $(GL_LIBS) -lcppunit
+ CXXTest_LDADD = ../src/libftgl.la
+ CTest_SOURCES = \
+ CTest.c \
+@@ -308,7 +308,7 @@ CTest_CPPFLAGS = \
+ -I$(top_srcdir)/src/FTLayout
+
+ CTest_CFLAGS = $(FT2_CFLAGS) $(GL_CFLAGS)
+-CTest_LDFLAGS = $(FT2_LIBS) $(GLUT_LIBS)
++CTest_LDFLAGS = $(FT2_LIBS) $(GLUT_LIBS) $(GL_LIBS)
+ CTest_LDADD = ../src/libftgl.la
+ NULL =
+ all: all-am
diff --git a/community/ftgl/ftgl-2.1.3-rc5-ttf_font.patch b/community/ftgl/ftgl-2.1.3-rc5-ttf_font.patch
new file mode 100644
index 0000000000..81ae273b30
--- /dev/null
+++ b/community/ftgl/ftgl-2.1.3-rc5-ttf_font.patch
@@ -0,0 +1,12 @@
+diff -up ftgl-2.1.3~rc5/demo/FTGLDemo.cpp.ttf_font ftgl-2.1.3~rc5/demo/FTGLDemo.cpp
+--- ftgl-2.1.3~rc5/demo/FTGLDemo.cpp.ttf_font 2008-06-08 17:49:10.000000000 +0200
++++ ftgl-2.1.3~rc5/demo/FTGLDemo.cpp 2009-05-21 02:18:42.000000000 +0200
+@@ -48,7 +48,7 @@
+ # define FONT_FILE "C:\\WINNT\\Fonts\\arial.ttf"
+ # else
+ // Put your font file here if configure did not find it.
+-# define FONT_FILE 0
++# define FONT_FILE "/usr/share/fonts/dejavu/DejaVuSans.ttf"
+ # endif
+ #endif
+