aboutsummaryrefslogtreecommitdiffstats
path: root/community/ghc/APKBUILD
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-05-24 14:51:47 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-05-24 14:53:19 +0200
commit061af43096c5e86becce3336f30b57d990c5544b (patch)
tree0c469a593bb898caa328c482507fdd58d6768a59 /community/ghc/APKBUILD
parent31aecc3f195e57d5a987638e4118ac34c6fb192e (diff)
downloadaports-061af43096c5e86becce3336f30b57d990c5544b.tar.bz2
aports-061af43096c5e86becce3336f30b57d990c5544b.tar.xz
community/ghc: add ghc-bootstrap to provides and makedepends
This is a hack to allow ghc depend on itself (read comment inside the abuild).
Diffstat (limited to 'community/ghc/APKBUILD')
-rw-r--r--community/ghc/APKBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/community/ghc/APKBUILD b/community/ghc/APKBUILD
index f1c5293157..8620c579f3 100644
--- a/community/ghc/APKBUILD
+++ b/community/ghc/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mitch Tishmack <mitch.tishmack@gmail.com>
pkgname=ghc
pkgver=8.0.2
-pkgrel=6
+pkgrel=7
pkgdesc="The Glasgow Haskell Compiler"
url="http://haskell.org"
arch="x86_64 armhf"
@@ -15,11 +15,18 @@ license="BSD-3-Clause"
# Ref: https://ghc.haskell.org/trac/ghc/wiki/Status/GHC-8.0.1
# https://ghc.haskell.org/trac/ghc/wiki/ImprovedLLVMBackend
depends="gmp-dev perl gcc>=6.2.1 llvm3.7 libffi-dev"
-makedepends_build="$pkgname autoconf cpio binutils-gold paxmark libffi-dev ncurses-dev"
+# ghc is self-hosted, so we need ghc to build ghc. ghc-bootstrap is provided by
+# this aport (see below).
+makedepends_build="$pkgname-bootstrap
+ autoconf cpio binutils-gold paxmark libffi-dev ncurses-dev"
makedepends_host="linux-headers musl-dev zlib-dev gmp-dev binutils-dev libffi-dev ncurses-dev"
makedepends="$makedepends_build $makedepends_host"
checkdepends="python2"
+# XXX: ghc-bootstrap is a hack to allow this abuild to depend on itself.
+# Adding "ghc" to makedepends would not work, because abuild implicitly removes
+# $pkgname and $subpackages from the abuild's dependencies.
provides="
+ $pkgname-bootstrap=$pkgver-r$pkgrel
haskell-cabal=1.24.2.0
haskell-bytestring=0.10.8.1
haskell-containers=0.5.7.1