aboutsummaryrefslogtreecommitdiffstats
path: root/community/gmime
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-04-11 16:08:07 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-04-11 16:08:07 +0000
commitaefa2b1f91908c9d0d88f0ca65fecd564c645d22 (patch)
treeddc39b9c3c89e281af23731adc724ea13e7c2cee /community/gmime
parent947a9e8e448391d3b148923e5479265bffc25cb6 (diff)
downloadaports-aefa2b1f91908c9d0d88f0ca65fecd564c645d22.tar.bz2
aports-aefa2b1f91908c9d0d88f0ca65fecd564c645d22.tar.xz
community/gmime: move from main
nothing in main needs it anymore
Diffstat (limited to 'community/gmime')
-rw-r--r--community/gmime/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/community/gmime/APKBUILD b/community/gmime/APKBUILD
new file mode 100644
index 0000000000..c7d0588de5
--- /dev/null
+++ b/community/gmime/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=gmime
+pkgver=3.2.0
+pkgrel=0
+pkgdesc="glib mime library"
+url="http://spruce.sourceforge.net/gmime/"
+arch="all"
+license="LGPL"
+depends_dev="glib-dev gpgme-dev"
+makedepends="$depends_dev intltool"
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://ftp.acc.umu.se/pub/GNOME/sources/gmime/${pkgver%.*}/gmime-$pkgver.tar.xz"
+
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="bb45f34b80ff237478602ff05ce0f736373185b7aa260c17aaf00a519d0b75ce9e24b0f6b256ce0f17b613e9f67174c54e302411110bf5f143947591f5f5aa43 gmime-3.2.0.tar.xz"