aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnome-colors
diff options
context:
space:
mode:
authorStuart Cardall <developer@it-offshore.co.uk>2016-08-18 20:46:53 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-21 22:24:04 +0200
commit5c9f3ca3e307be53b45beeed2ce1626f38008625 (patch)
tree919836fe454e953f46685adf8228b0401280d4b6 /community/gnome-colors
parent6a00a953ba02bab6440a2c784e7db37c6eaeace1 (diff)
downloadaports-5c9f3ca3e307be53b45beeed2ce1626f38008625.tar.bz2
aports-5c9f3ca3e307be53b45beeed2ce1626f38008625.tar.xz
testing/[various]: move to community
albatross-themes apk-post-messages autossh bitcoin btrbk entr ffmpegthumbnailer firejail firetools fwsnort gnome-colors imapsync inetutils-syslogd inotify-tools-inc isync junit ktsuss letsencrypt-nosudo libmbim libndp libqmi libteam mini-sendmail modemmanager namecoin networkmanager nginx-naxsi numix-themes nxapi opencl-headers opencl-icd-loader opus-tools perl-authen-ntlm perl-bit-vector perl-data-uniqid perl-file-copy-recursive perl-getopt-argvfile perl-io-tee perl-iptables-chainmgr perl-iptables-parse perl-module-scandeps perl-par-dist perl-par-packer perl-par perl-uri-escape psad py-crcmod py-graphviz py-lz4 py-opencl py-opengl-accelerate runit secpwgen secure-delete socklog spacefm tinyssh udevil virt-viewer virtualbricks whois wrk xpra zram-init
Diffstat (limited to 'community/gnome-colors')
-rw-r--r--community/gnome-colors/APKBUILD75
1 files changed, 75 insertions, 0 deletions
diff --git a/community/gnome-colors/APKBUILD b/community/gnome-colors/APKBUILD
new file mode 100644
index 0000000000..ba192241ca
--- /dev/null
+++ b/community/gnome-colors/APKBUILD
@@ -0,0 +1,75 @@
+# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
+# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
+pkgname=gnome-colors
+pkgver=5.5.1
+pkgrel=1
+pkgdesc="gnome-colors icon themes meta package (all themes)"
+url="https://code.google.com/p/gnome-colors/"
+arch="noarch"
+license="GPLv2"
+subpackages="$pkgname-common
+ gnome-brave-icon-theme:brave
+ gnome-dust-icon-theme:dust
+ gnome-human-icon-theme:human
+ gnome-illustrious-icon-theme:illustrious
+ gnome-noble-icon-theme:noble
+ gnome-wine-icon-theme:wine
+ gnome-wise-icon-theme:wise
+ "
+depends="$pkgname-common gnome-brave-icon-theme gnome-dust-icon-theme gnome-human-icon-theme
+ gnome-illustrious-icon-theme gnome-noble-icon-theme gnome-wine-icon-theme gnome-wise-icon-theme"
+
+source="https://gnome-colors.googlecode.com/files/gnome-colors-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ mkdir $_builddir
+ ls -1 | egrep -v "$pkgver|.patch" | xargs -I{} mv {} $_builddir/
+}
+
+package() {
+ cd "$_builddir" || return 1
+ find gnome* -name 'xchat*' | while read i; do
+ ln -s "${i##*/}" "${i/xchat/hexchat}" || break
+ done
+ mkdir -p "$pkgdir/$pkgname"
+}
+
+_app() {
+ local app="$1" final_name= color=
+ vmsg="variation of the" cmsg="icons for all"
+
+ case "$app" in
+ brave) color="Blue $vmsg";;
+ colors-common) color="Common $cmsg";;
+ dust) color="Chocolate $vmsg";;
+ human) color="Orange $vmsg";;
+ illustrious) color="Pink $vmsg";;
+ noble) color="Purple $vmsg";;
+ wine) color="Red $vmsg";;
+ wise) color="Green $vmsg";;
+ esac
+
+ pkgdesc="$color GNOME-Colors icon theme"
+ if [ "$app" != "colors-common" ]; then
+ depends="$pkgname-common"
+ fi
+
+ cd "$_builddir"
+ mkdir -p "$subpkgdir/usr/share/icons"
+ mv "gnome-$app" "$subpkgdir/usr/share/icons/" || return 1
+}
+
+brave() { _app brave 'brave*'; }
+common() { _app colors-common 'colors-common*'; }
+dust() { _app dust 'dust*'; }
+human() { _app human 'human*'; }
+illustrious() { _app illustrious 'illustrious*'; }
+noble() { _app noble 'noble*'; }
+wine() { _app wine 'wine*'; }
+wise() { _app wise 'wise*'; }
+
+md5sums="8ec81b556bac351817bd56a1701dbbfb gnome-colors-5.5.1.tar.gz"
+sha256sums="1e91d845a753eb38671e7614a786f852ab858a12983111e780da4a47c9debe58 gnome-colors-5.5.1.tar.gz"
+sha512sums="23d1fb9b96cd4287acc0f540c8a7abed1b9f16d7e2bc952beedc365cfd71a3a0134382a7f4bb1c01c62dc376acb6aaf81332167869ec6e8c036679e89d325ff3 gnome-colors-5.5.1.tar.gz"