aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnome-keyring
diff options
context:
space:
mode:
authorBartłomiej Piotrowski <b@bpiotrowski.pl>2015-11-09 12:11:12 +0100
committerBartłomiej Piotrowski <b@bpiotrowski.pl>2015-11-09 12:11:12 +0100
commitdd0d32a03ac74e998d54a0c8f6e84394151777f2 (patch)
tree43cb353191e60720e1563c8c6abb27fc3be20ec8 /community/gnome-keyring
parent4b9096b304c556fc26e8af78ec222b5a4b5d0fbd (diff)
downloadaports-dd0d32a03ac74e998d54a0c8f6e84394151777f2.tar.bz2
aports-dd0d32a03ac74e998d54a0c8f6e84394151777f2.tar.xz
main/gnome-keyring: move to community
Diffstat (limited to 'community/gnome-keyring')
-rw-r--r--community/gnome-keyring/APKBUILD56
-rw-r--r--community/gnome-keyring/fix-includes.patch10
2 files changed, 66 insertions, 0 deletions
diff --git a/community/gnome-keyring/APKBUILD b/community/gnome-keyring/APKBUILD
new file mode 100644
index 0000000000..d75bf66c85
--- /dev/null
+++ b/community/gnome-keyring/APKBUILD
@@ -0,0 +1,56 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=gnome-keyring
+pkgver=3.16.0
+pkgrel=0
+pkgdesc="GNOME keyring"
+url="http://www.gnome.org"
+arch="all"
+license="GPL"
+depends=
+depends_dev="gtk+3.0-dev
+ gcr-dev
+ libcap-ng-dev"
+makedepends="$depends_dev gtk-doc intltool gobject-introspection-dev"
+install=
+subpackages="$pkgname-lang"
+source="ftp://ftp.gnome.org/pub/GNOME/sources/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.xz
+ fix-includes.patch
+ "
+
+_builddir="${srcdir}/${pkgname}-${pkgver}"
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+
+ export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="d105927a8dd1791552882744b62351bd gnome-keyring-3.16.0.tar.xz
+e70751be048bf0debabc6d3c5d10658e fix-includes.patch"
+sha256sums="15a3bb8c53855a4ff0dbbdfbe4ec3df206c32048f50bdc76a51f8e3e14ece1f5 gnome-keyring-3.16.0.tar.xz
+eeab3d71e26585d65f40f443486177cde05d4819f8457e1ab24c7075c389cc6b fix-includes.patch"
+sha512sums="eeb5c614395dda0e046056899f9eb6f962253b48d6b668bb966328e75863010c1f653ba2d8f7ca60bdd8ff5c43f77604396f0e4c448236c5b010dd0c61ffa069 gnome-keyring-3.16.0.tar.xz
+99af8b23c8b53bc1e70f921c872563b779c1ec59db72474b62e6d693f0d82d38b94607c8b9d53e751cf4a44873c91e283bc27d69f37433a37aa40e990caa1249 fix-includes.patch"
diff --git a/community/gnome-keyring/fix-includes.patch b/community/gnome-keyring/fix-includes.patch
new file mode 100644
index 0000000000..e8e3e20f52
--- /dev/null
+++ b/community/gnome-keyring/fix-includes.patch
@@ -0,0 +1,10 @@
+--- gnome-keyring-2.32.1.orig/pkcs11/rpc-layer/gkm-rpc-daemon-standalone.c
++++ gnome-keyring-2.32.1/pkcs11/rpc-layer/gkm-rpc-daemon-standalone.c
+@@ -32,6 +32,7 @@
+ #include <unistd.h>
+ #include <stdlib.h>
+ #include <string.h>
++#include <sys/select.h>
+
+ #include <dlfcn.h>
+ #include <pthread.h>