aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnome-power-manager
diff options
context:
space:
mode:
authorBartłomiej Piotrowski <b@bpiotrowski.pl>2015-11-09 12:11:12 +0100
committerBartłomiej Piotrowski <b@bpiotrowski.pl>2015-11-09 12:11:12 +0100
commit499dd4be3c8864b8411c58192ac164bbfd2f1df7 (patch)
tree72392abc3ebd8149f08faeaa3cbef2a6fb05c295 /community/gnome-power-manager
parent4f8661131edab83465dbf3a817fd0506b2dc5541 (diff)
downloadaports-499dd4be3c8864b8411c58192ac164bbfd2f1df7.tar.bz2
aports-499dd4be3c8864b8411c58192ac164bbfd2f1df7.tar.xz
main/gnome-power-manager: move to community
Diffstat (limited to 'community/gnome-power-manager')
-rw-r--r--community/gnome-power-manager/APKBUILD49
-rw-r--r--community/gnome-power-manager/execinfo.patch26
-rw-r--r--community/gnome-power-manager/gnome-power-manager-2.32.0-libnotify-0.7.patch30
-rw-r--r--community/gnome-power-manager/gnome-power-manager.post-install7
-rw-r--r--community/gnome-power-manager/gnome-power-manager.post-upgrade7
-rw-r--r--community/gnome-power-manager/gnome-power-manager.pre-deinstall7
6 files changed, 126 insertions, 0 deletions
diff --git a/community/gnome-power-manager/APKBUILD b/community/gnome-power-manager/APKBUILD
new file mode 100644
index 0000000000..249a31929d
--- /dev/null
+++ b/community/gnome-power-manager/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=gnome-power-manager
+pkgver=3.16.1
+pkgrel=0
+pkgdesc="GNOME power manager"
+url="http://www.gnome.org"
+arch="all"
+license="GPL"
+depends=
+depends_dev="gtk+3.0-dev"
+makedepends="$depends_dev intltool gobject-introspection-dev upower-dev"
+install="$pkgname.post-install $pkgname.pre-deinstall $pkgname.post-upgrade"
+subpackages="$pkgname-lang"
+source="ftp://ftp.gnome.org/pub/GNOME/sources/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.xz
+ "
+
+_builddir="${srcdir}/${pkgname}-${pkgver}"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+
+ export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="dfe80c3fe370e790bac0a8837f2f5bc9 gnome-power-manager-3.16.1.tar.xz"
+sha256sums="a4177dbff9fac1f1babf0d2715f950ee0fa3dd143d7b5d89311f33afca924231 gnome-power-manager-3.16.1.tar.xz"
+sha512sums="b4f04196f88bb43eaefc910e733cb291fd88c260baae275595fa1e9913ccb2577ea2192238c6bf18297c4cc69b0d0e88571b96ee526f37ad260f6e1b429488da gnome-power-manager-3.16.1.tar.xz"
diff --git a/community/gnome-power-manager/execinfo.patch b/community/gnome-power-manager/execinfo.patch
new file mode 100644
index 0000000000..c9def1be10
--- /dev/null
+++ b/community/gnome-power-manager/execinfo.patch
@@ -0,0 +1,26 @@
+--- gnome-power-manager-2.32.0.orig/src/egg-debug.c
++++ gnome-power-manager-2.32.0/src/egg-debug.c
+@@ -39,7 +39,6 @@
+ #include <sys/stat.h>
+ #include <fcntl.h>
+ #include <time.h>
+-#include <execinfo.h>
+
+ #include "egg-debug.h"
+
+@@ -78,6 +77,7 @@
+ void
+ egg_debug_backtrace (void)
+ {
++#if 0
+ void *call_stack[512];
+ int call_stack_size;
+ char **symbols;
+@@ -95,6 +95,7 @@
+ pk_set_console_mode (CONSOLE_RESET);
+ free (symbols);
+ }
++#endif
+ }
+
+ /**
diff --git a/community/gnome-power-manager/gnome-power-manager-2.32.0-libnotify-0.7.patch b/community/gnome-power-manager/gnome-power-manager-2.32.0-libnotify-0.7.patch
new file mode 100644
index 0000000000..022d2c5fe5
--- /dev/null
+++ b/community/gnome-power-manager/gnome-power-manager-2.32.0-libnotify-0.7.patch
@@ -0,0 +1,30 @@
+--- ./src/gpm-manager.c
++++ ./src/gpm-manager.c
+@@ -43,6 +43,10 @@
+ #include <libupower-glib/upower.h>
+ #include <libnotify/notify.h>
+
++#ifndef NOTIFY_CHECK_VERSION
++#define NOTIFY_CHECK_VERSION(x,y,z) 0
++#endif
++
+ #include "egg-debug.h"
+ #include "egg-console-kit.h"
+
+@@ -480,12 +484,16 @@
+ /* close any existing notification of this class */
+ gpm_manager_notify_close (manager, *notification_class);
+
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ notification = notify_notification_new (title, message, icon);
++#else
+ /* if the status icon is hidden, don't point at it */
+ if (manager->priv->status_icon != NULL &&
+ gtk_status_icon_is_embedded (manager->priv->status_icon))
+ notification = notify_notification_new_with_status_icon (title, message, icon, manager->priv->status_icon);
+ else
+ notification = notify_notification_new (title, message, icon, NULL);
++#endif
+ notify_notification_set_timeout (notification, timeout);
+ notify_notification_set_urgency (notification, urgency);
+ g_signal_connect (notification, "closed", G_CALLBACK (gpm_manager_notification_closed_cb), notification_class);
diff --git a/community/gnome-power-manager/gnome-power-manager.post-install b/community/gnome-power-manager/gnome-power-manager.post-install
new file mode 100644
index 0000000000..8d6b50a50e
--- /dev/null
+++ b/community/gnome-power-manager/gnome-power-manager.post-install
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+for i in gnome-power-manager.schemas; do
+ echo "Installing GConf2 schema $i."
+ GCONF_CONFIG_SOURCE=`/usr/bin/gconftool-2 --get-default-source` \
+ /usr/bin/gconftool-2 --makefile-install-rule /etc/gconf/schemas/$i >/dev/null
+done
diff --git a/community/gnome-power-manager/gnome-power-manager.post-upgrade b/community/gnome-power-manager/gnome-power-manager.post-upgrade
new file mode 100644
index 0000000000..8d6b50a50e
--- /dev/null
+++ b/community/gnome-power-manager/gnome-power-manager.post-upgrade
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+for i in gnome-power-manager.schemas; do
+ echo "Installing GConf2 schema $i."
+ GCONF_CONFIG_SOURCE=`/usr/bin/gconftool-2 --get-default-source` \
+ /usr/bin/gconftool-2 --makefile-install-rule /etc/gconf/schemas/$i >/dev/null
+done
diff --git a/community/gnome-power-manager/gnome-power-manager.pre-deinstall b/community/gnome-power-manager/gnome-power-manager.pre-deinstall
new file mode 100644
index 0000000000..ed1e2c420a
--- /dev/null
+++ b/community/gnome-power-manager/gnome-power-manager.pre-deinstall
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+for i in gnome-power-manager.schemas; do
+ echo "Uninstalling GConf2 schema $i."
+ GCONF_CONFIG_SOURCE=`/usr/bin/gconftool-2 --get-default-source` \
+ /usr/bin/gconftool-2 --makefile-uninstall-rule /etc/gconf/schemas/$i >/dev/null
+done