aboutsummaryrefslogtreecommitdiffstats
path: root/community/go-gdm
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@alpinelinux.org>2018-05-09 08:31:27 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2018-05-09 08:31:27 +0000
commit574825b112b91e573747638750571312b54a8f63 (patch)
treeb963c793178ff479a64f55848784d112eb418a60 /community/go-gdm
parentbb92119889eafa082eee9cd178873fd23107fb6b (diff)
downloadaports-574825b112b91e573747638750571312b54a8f63.tar.bz2
aports-574825b112b91e573747638750571312b54a8f63.tar.xz
testing/go-gdm: move to community
Diffstat (limited to 'community/go-gdm')
-rw-r--r--community/go-gdm/APKBUILD46
-rw-r--r--community/go-gdm/Godeps.json11
2 files changed, 57 insertions, 0 deletions
diff --git a/community/go-gdm/APKBUILD b/community/go-gdm/APKBUILD
new file mode 100644
index 0000000000..f0cc7b8a39
--- /dev/null
+++ b/community/go-gdm/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor: Stefan Wagner <stw@bit-strickerei.de>
+# Maintainer: Stefan Wagner <stw@bit-strickerei.de>
+pkgname=go-gdm
+_pkgname=gdm
+pkgver=1.4
+pkgrel=0
+pkgdesc="Minimalist dependency manager for Go written in Go."
+url="https://github.com/sparrc/gdm"
+arch="all"
+license="Unlicense"
+depends="go"
+makedepends="godep"
+install=""
+subpackages=""
+source="$_pkgname-$pkgver.tar.gz::https://github.com/sparrc/$_pkgname/archive/$pkgver.tar.gz
+ Godeps.json
+ "
+builddir="$srcdir/go/src/github.com/sparrc/$_pkgname"
+options="!check" # has not tests
+
+prepare() {
+ mkdir -p "$srcdir/go/src/github.com/sparrc"
+ mv "$srcdir/$_pkgname-$pkgver" "$builddir"
+ rm "$builddir/Godeps"
+ mkdir -p "$builddir/Godeps"
+ mv "$srcdir/Godeps.json" "$builddir/Godeps/Godeps.json"
+ export GOPATH="$srcdir/go"
+ cd "$builddir"
+ godep get
+
+ default_prepare
+}
+
+build() {
+ export GOPATH="$srcdir/go"
+ cd "$builddir"
+ go build -v -o gdm -ldflags "-X main.version=$pkgver" || return 1
+}
+
+package() {
+ cd "$builddir"
+ install -sD -m 755 gdm "$pkgdir"/usr/bin/gdm
+}
+
+sha512sums="43d533536a44e742bfe7921e1e2f383f6ab016cd8beac6a426634737f8ccee0a7a35da888340994fa4e3023c12507c014d7713cb37cec054b30ce95495ebfc8a gdm-1.4.tar.gz
+362add994473d3907703012ffbb863ddc6a6f61ff69486d834c60ec368a101f470bb2569f39c47df6e0b3f40b0d4f76d421e1854054c38d976f8ecb4a2c3299a Godeps.json"
diff --git a/community/go-gdm/Godeps.json b/community/go-gdm/Godeps.json
new file mode 100644
index 0000000000..bf506d0f9b
--- /dev/null
+++ b/community/go-gdm/Godeps.json
@@ -0,0 +1,11 @@
+{
+ "ImportPath": "github.com/sparrc/gdm/gdm-1.4",
+ "GoVersion": "go1.9",
+ "GodepVersion": "v75",
+ "Deps": [
+ {
+ "ImportPath": "golang.org/x/tools/go/vcs",
+ "Rev": "6f233b96dfbc53e33b302e31b88814cf74697ff6"
+ }
+ ]
+}