aboutsummaryrefslogtreecommitdiffstats
path: root/community/godep
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2018-07-02 17:45:28 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2018-07-02 17:45:28 +0000
commitea99764355806503a4348620faa7ee55baceae53 (patch)
treeaee1150a7f6b82ea718f99f1f2d86cffec243395 /community/godep
parent2328e6e6ea23b4206291fba04e8dae2cbb871c7f (diff)
downloadaports-ea99764355806503a4348620faa7ee55baceae53.tar.bz2
aports-ea99764355806503a4348620faa7ee55baceae53.tar.xz
community/godep: add check
Diffstat (limited to 'community/godep')
-rw-r--r--community/godep/APKBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/community/godep/APKBUILD b/community/godep/APKBUILD
index 200e87e2f3..94b4a2c6d5 100644
--- a/community/godep/APKBUILD
+++ b/community/godep/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Roberto Oliveira <robertoguimaraes8@gmail.com>
pkgname=godep
pkgver=80
-pkgrel=0
+pkgrel=1
pkgdesc="Dependency tool for go"
url="https://github.com/tools/godep"
arch="all"
@@ -23,6 +23,11 @@ build() {
GOPATH="$srcdir" go build
}
+check() {
+ cd "$builddir"
+ GOPATH="$srcdir" go test
+}
+
package() {
install -D -m 755 "$builddir"/$pkgname "$pkgdir"/usr/bin/godep
}