aboutsummaryrefslogtreecommitdiffstats
path: root/community/gst-plugins-bad
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-05-16 16:08:29 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-05-16 16:26:48 +0000
commit3115cc7982e319dc2e97f0b0fc1ec1607b90d998 (patch)
treec8bc27091f5c1d525da3a5f22d9f990a7975c8a3 /community/gst-plugins-bad
parent7151ceb8929179657c74ab10712965d39f417c44 (diff)
downloadaports-3115cc7982e319dc2e97f0b0fc1ec1607b90d998.tar.bz2
aports-3115cc7982e319dc2e97f0b0fc1ec1607b90d998.tar.xz
move main/gst-plugins-{good,bad,ugly}* to community
gst-plugins needs qt
Diffstat (limited to 'community/gst-plugins-bad')
-rw-r--r--community/gst-plugins-bad/APKBUILD79
-rw-r--r--community/gst-plugins-bad/libressl270-dtsl_method.patch18
2 files changed, 97 insertions, 0 deletions
diff --git a/community/gst-plugins-bad/APKBUILD b/community/gst-plugins-bad/APKBUILD
new file mode 100644
index 0000000000..e89fb93348
--- /dev/null
+++ b/community/gst-plugins-bad/APKBUILD
@@ -0,0 +1,79 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=gst-plugins-bad
+pkgver=1.14.0
+pkgrel=1
+pkgdesc="GStreamer bad plugins"
+url="https://gstreamer.freedesktop.org/"
+arch="all"
+license="GPL-2.0-or-later LGPL-2.0-or-later"
+replaces="gst-plugins-bad1"
+options="!check" # most fail because: XDG_RUNTIME_DIR not set in the env.
+makedepends="
+ alsa-lib-dev
+ bluez-dev
+ bzip2-dev
+ curl-dev
+ faac-dev
+ faad2-dev
+ flite-dev
+ glib-dev
+ glu-dev
+ gsm-dev
+ gst-plugins-base-dev
+ gstreamer-dev
+ libdc1394-dev
+ libexif-dev
+ libmms-dev
+ libmodplug-dev
+ libressl-dev>=2.7.0
+ librsvg-dev
+ libvdpau-dev
+ libx11-dev
+ mesa-dev
+ neon-dev
+ orc-dev
+ directfb-dev
+ spandsp-dev
+ libwebp-dev
+ x265-dev
+ libass-dev
+ libsrtp-dev
+ orc-compiler
+ "
+subpackages="$pkgname-lang $pkgname-dev $pkgname-doc"
+source="https://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-$pkgver.tar.xz
+ libressl270-dtsl_method.patch"
+ldpath="/usr/lib/gstreamer-1.0"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --disable-static \
+ --enable-experimental \
+ --disable-fatal-warnings \
+ --with-package-name="GStreamer Bad Plugins (Alpine Linux)" \
+ --with-package-origin="http://alpinelinux.org/"
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+doc() {
+ default_doc
+ replaces="${pkgname}1-doc"
+}
+sha512sums="3f64dc428e2c1890f05d2c718215ff4b78a8262255ea61e746b436dc9ce1d3e0671db9cf3640f9a7453434297cac3a134272de7785818dfc5a6011ce8584842f gst-plugins-bad-1.14.0.tar.xz
+82106a8fa7ac01c63c3298c33a3b6177a4115f380d475634ea8ba4c67654f96275ab4b35eb4ea712a997165fefa7e9b65fd6b14ed3cea478c200d7e8d61423c4 libressl270-dtsl_method.patch"
diff --git a/community/gst-plugins-bad/libressl270-dtsl_method.patch b/community/gst-plugins-bad/libressl270-dtsl_method.patch
new file mode 100644
index 0000000000..6ea6085180
--- /dev/null
+++ b/community/gst-plugins-bad/libressl270-dtsl_method.patch
@@ -0,0 +1,18 @@
+--- a/ext/dtls/gstdtlsagent.c
++++ b/ext/dtls/gstdtlsagent.c
+@@ -176,11 +176,11 @@
+
+ ERR_clear_error ();
+
+-#if OPENSSL_VERSION_NUMBER >= 0x1000200fL
+- priv->ssl_context = SSL_CTX_new (DTLS_method ());
+-#else
++//#if OPENSSL_VERSION_NUMBER >= 0x1000200fL
++ // priv->ssl_context = SSL_CTX_new (DTLS_method ());
++//#else
+ priv->ssl_context = SSL_CTX_new (DTLSv1_method ());
+-#endif
++//#endif
+ if (ERR_peek_error () || !priv->ssl_context) {
+ char buf[512];
+