aboutsummaryrefslogtreecommitdiffstats
path: root/community/gst-plugins-good0.10
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-05-16 16:08:29 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-05-16 16:26:48 +0000
commit3115cc7982e319dc2e97f0b0fc1ec1607b90d998 (patch)
treec8bc27091f5c1d525da3a5f22d9f990a7975c8a3 /community/gst-plugins-good0.10
parent7151ceb8929179657c74ab10712965d39f417c44 (diff)
downloadaports-3115cc7982e319dc2e97f0b0fc1ec1607b90d998.tar.bz2
aports-3115cc7982e319dc2e97f0b0fc1ec1607b90d998.tar.xz
move main/gst-plugins-{good,bad,ugly}* to community
gst-plugins needs qt
Diffstat (limited to 'community/gst-plugins-good0.10')
-rw-r--r--community/gst-plugins-good0.10/0001-sys-v4l2-Some-blind-compilation-fixes.patch57
-rw-r--r--community/gst-plugins-good0.10/APKBUILD63
-rw-r--r--community/gst-plugins-good0.10/gst-plugins-good-gnome.post-install7
-rw-r--r--community/gst-plugins-good0.10/gst-plugins-good-gnome.post-upgrade7
-rw-r--r--community/gst-plugins-good0.10/gst-plugins-good-gnome.pre-deinstall7
5 files changed, 141 insertions, 0 deletions
diff --git a/community/gst-plugins-good0.10/0001-sys-v4l2-Some-blind-compilation-fixes.patch b/community/gst-plugins-good0.10/0001-sys-v4l2-Some-blind-compilation-fixes.patch
new file mode 100644
index 0000000000..e03fdac894
--- /dev/null
+++ b/community/gst-plugins-good0.10/0001-sys-v4l2-Some-blind-compilation-fixes.patch
@@ -0,0 +1,57 @@
+From fa21c0bb253213c9dc48ce72faaf7090dc8a3554 Mon Sep 17 00:00:00 2001
+From: Colin Walters <walters@verbum.org>
+Date: Thu, 2 May 2013 16:16:46 -0400
+Subject: [PATCH] sys/v4l2: Some blind compilation fixes
+
+---
+ sys/v4l2/gstv4l2bufferpool.c | 1 -
+ sys/v4l2/v4l2_calls.c | 12 ++++--------
+ 2 files changed, 4 insertions(+), 9 deletions(-)
+
+diff --git a/sys/v4l2/gstv4l2bufferpool.c b/sys/v4l2/gstv4l2bufferpool.c
+index a0b4c84..3916815 100644
+--- a/sys/v4l2/gstv4l2bufferpool.c
++++ b/sys/v4l2/gstv4l2bufferpool.c
+@@ -182,7 +182,6 @@ gst_v4l2_buffer_new (GstV4l2BufferPool * pool, guint index, GstCaps * caps)
+ GST_LOG_OBJECT (pool->v4l2elem, " MMAP offset: %u",
+ ret->vbuffer.m.offset);
+ GST_LOG_OBJECT (pool->v4l2elem, " length: %u", ret->vbuffer.length);
+- GST_LOG_OBJECT (pool->v4l2elem, " input: %u", ret->vbuffer.input);
+
+ ret->mmap_length = ret->vbuffer.length;
+ data = (guint8 *) v4l2_mmap (0, ret->vbuffer.length,
+diff --git a/sys/v4l2/v4l2_calls.c b/sys/v4l2/v4l2_calls.c
+index 309bfb6..ee3ff9f 100644
+--- a/sys/v4l2/v4l2_calls.c
++++ b/sys/v4l2/v4l2_calls.c
+@@ -53,14 +53,6 @@
+
+ #include "gst/gst-i18n-plugin.h"
+
+-/* Those are ioctl calls */
+-#ifndef V4L2_CID_HCENTER
+-#define V4L2_CID_HCENTER V4L2_CID_HCENTER_DEPRECATED
+-#endif
+-#ifndef V4L2_CID_VCENTER
+-#define V4L2_CID_VCENTER V4L2_CID_VCENTER_DEPRECATED
+-#endif
+-
+ GST_DEBUG_CATEGORY_EXTERN (v4l2_debug);
+ #define GST_CAT_DEFAULT v4l2_debug
+
+@@ -294,8 +286,12 @@ gst_v4l2_fill_lists (GstV4l2Object * v4l2object)
+ break;
+ case V4L2_CID_HFLIP:
+ case V4L2_CID_VFLIP:
++#ifdef V4L2_CID_HCENTER
+ case V4L2_CID_HCENTER:
++#endif
++#ifdef V4L2_CID_VCENTER
+ case V4L2_CID_VCENTER:
++#endif
+ #ifdef V4L2_CID_PAN_RESET
+ case V4L2_CID_PAN_RESET:
+ #endif
+--
+1.7.1
+
diff --git a/community/gst-plugins-good0.10/APKBUILD b/community/gst-plugins-good0.10/APKBUILD
new file mode 100644
index 0000000000..c713182a9c
--- /dev/null
+++ b/community/gst-plugins-good0.10/APKBUILD
@@ -0,0 +1,63 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=gst-plugins-good0.10
+pkgver=0.10.31
+pkgrel=1
+pkgdesc="GStreamer Multimedia Framework Good Plugins"
+url="https://gstreamer.freedesktop.org/"
+arch="all"
+license="LGPL"
+subpackages="$pkgname-lang"
+depends=
+replaces="gst-plugins-good"
+depends_dev="gstreamer0.10-dev gst-plugins-base0.10-dev"
+makedepends="linux-headers $depends_dev glib-dev orc-dev
+ libsoup-dev flac-dev libogg-dev taglib-dev libjpeg-turbo-dev zlib-dev
+ wavpack-dev libavc1394-dev libiec61883-dev libshout-dev libdv-dev
+ orc-dev libxext libsm-dev libice-dev libxv-dev"
+
+source="https://gstreamer.freedesktop.org/src/gst-plugins-good/gst-plugins-good-$pkgver.tar.bz2
+ 0001-sys-v4l2-Some-blind-compilation-fixes.patch
+ "
+
+
+_builddir="$srcdir"/gst-plugins-good-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ update_config_sub || return 1
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --disable-static \
+ --enable-experimental \
+ --with-package-name="GStreamer Good Plugins (Alpine Linux)" \
+ --with-package-origin="http://www.alpinelinux.org/" \
+ || return 1
+ make
+}
+
+package() {
+ cd "$_builddir"
+
+ export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="24f98a294a2b521e1b29412bdadae2e6 gst-plugins-good-0.10.31.tar.bz2
+50a54d7ad0ce0903e25d7059ccd157e4 0001-sys-v4l2-Some-blind-compilation-fixes.patch"
+sha256sums="7e27840e40a7932ef2dc032d7201f9f41afcaf0b437daf5d1d44dc96d9e35ac6 gst-plugins-good-0.10.31.tar.bz2
+24f615180a99c2034d81d783c3f8ac5493205966e272daaff5cb1d06e08e0a2f 0001-sys-v4l2-Some-blind-compilation-fixes.patch"
+sha512sums="dc81eb37cdd9f656419d967347a9b85ce51ae5733680317ac2c84d82816b6dbd1117ae3ef1a5c7d01e90cdc791d3d27ee9e8355a2793ea381a873809c9566bbe gst-plugins-good-0.10.31.tar.bz2
+de2f1257f2341b01cdf2832a40ed6979c04b86ee89a70f9649ff46bf4255cae5f969a4f8f864d39fed7352edb0184c6b5954ac0f27a20cefce61dde25ad36190 0001-sys-v4l2-Some-blind-compilation-fixes.patch"
diff --git a/community/gst-plugins-good0.10/gst-plugins-good-gnome.post-install b/community/gst-plugins-good0.10/gst-plugins-good-gnome.post-install
new file mode 100644
index 0000000000..35c28f3eba
--- /dev/null
+++ b/community/gst-plugins-good0.10/gst-plugins-good-gnome.post-install
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+for i in gstreamer-0.10.schemas; do
+ echo "Installing GConf2 schema $i."
+ GCONF_CONFIG_SOURCE=`/usr/bin/gconftool-2 --get-default-source` \
+ /usr/bin/gconftool-2 --makefile-install-rule /etc/gconf/schemas/$i >/dev/null
+done
diff --git a/community/gst-plugins-good0.10/gst-plugins-good-gnome.post-upgrade b/community/gst-plugins-good0.10/gst-plugins-good-gnome.post-upgrade
new file mode 100644
index 0000000000..35c28f3eba
--- /dev/null
+++ b/community/gst-plugins-good0.10/gst-plugins-good-gnome.post-upgrade
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+for i in gstreamer-0.10.schemas; do
+ echo "Installing GConf2 schema $i."
+ GCONF_CONFIG_SOURCE=`/usr/bin/gconftool-2 --get-default-source` \
+ /usr/bin/gconftool-2 --makefile-install-rule /etc/gconf/schemas/$i >/dev/null
+done
diff --git a/community/gst-plugins-good0.10/gst-plugins-good-gnome.pre-deinstall b/community/gst-plugins-good0.10/gst-plugins-good-gnome.pre-deinstall
new file mode 100644
index 0000000000..5facd9964d
--- /dev/null
+++ b/community/gst-plugins-good0.10/gst-plugins-good-gnome.pre-deinstall
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+for i in gstreamer-0.10.schemas; do
+ echo "Uninstalling GConf2 schema $i."
+ GCONF_CONFIG_SOURCE=`/usr/bin/gconftool-2 --get-default-source` \
+ /usr/bin/gconftool-2 --makefile-uninstall-rule /etc/gconf/schemas/$i >/dev/null
+done