aboutsummaryrefslogtreecommitdiffstats
path: root/community/gwenhywfar
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2017-11-06 11:48:55 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2017-11-06 12:30:37 +0100
commit2ab911b8ee651a8c7d752e91ba4a67c429566394 (patch)
treebcfef3c4126f4cd7cd5d04e44111a0e8ee15f847 /community/gwenhywfar
parent2a4e436ca56e4d7cf52033443f5f37d31f3b38df (diff)
downloadaports-2ab911b8ee651a8c7d752e91ba4a67c429566394.tar.bz2
aports-2ab911b8ee651a8c7d752e91ba4a67c429566394.tar.xz
community/gwenhywfar: move from testing
Diffstat (limited to 'community/gwenhywfar')
-rw-r--r--community/gwenhywfar/APKBUILD58
-rw-r--r--community/gwenhywfar/fix-tests.patch23
-rw-r--r--community/gwenhywfar/libintl.patch12
3 files changed, 93 insertions, 0 deletions
diff --git a/community/gwenhywfar/APKBUILD b/community/gwenhywfar/APKBUILD
new file mode 100644
index 0000000000..04c1ac9c4f
--- /dev/null
+++ b/community/gwenhywfar/APKBUILD
@@ -0,0 +1,58 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
+pkgname=gwenhywfar
+pkgver=4.18.0
+_pkgrel=206
+pkgrel=0
+pkgdesc="Multi-platform helper library"
+url="http://www.aquamaniac.de/"
+arch="all"
+license="LGPL"
+depends=""
+depends_dev=""
+makedepends="libgcrypt-dev gnutls-dev gettext-dev
+ automake autoconf libtool bash"
+install=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+source="$pkgname-$pkgver.tar.gz::https://www.aquamaniac.de/sites/download/download.php?package=01&release=${_pkgrel}&file=01&dummy=$pkgname-$pkgver.tar.gz
+ libintl.patch
+ fix-tests.patch"
+builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ default_prepare
+ cd "$builddir"
+ autoreconf -vfi
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --with-guis= \
+ --enable-ssl \
+ --enable-visibility
+ make
+}
+
+check() {
+ make -C "$builddir" check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+
+ mkdir -p "$pkgdir"/usr/share/doc/$pkgname
+ install -m644 AUTHORS ChangeLog README TODO \
+ "$pkgdir"/usr/share/doc/$pkgname
+}
+
+sha512sums="3225a6eb06c8a0e53433b0cbac75818521664f2449905847747a4808d54ffaf3dfe597e71666accea28f5fc69f582f0e35942b128c7c96e788eed6e03ab894b4 gwenhywfar-4.18.0.tar.gz
+fcccf5aa3872f4327205c3c77c5e1b88fbce89d6fe45330f72a38c207b7f6166ca486e70636119a9c16447a3c09e3bad97ed7a1cc5f06db53939f510e2c19cca libintl.patch
+62a127684b5d0900edf3f78b884285e63ea43d076b03c265cb59834e915fb68be61601bd54a6c991b20e793d511a5826fde22312e3fe3b2686d993cf32dd3869 fix-tests.patch"
diff --git a/community/gwenhywfar/fix-tests.patch b/community/gwenhywfar/fix-tests.patch
new file mode 100644
index 0000000000..00051f551b
--- /dev/null
+++ b/community/gwenhywfar/fix-tests.patch
@@ -0,0 +1,23 @@
+Port 443 is not open on devel.aqbanking.de connect to google.com instead.
+
+diff -upr gwenhywfar-4.18.0.orig/checks/syncio_https.c gwenhywfar-4.18.0/checks/syncio_https.c
+--- gwenhywfar-4.18.0.orig/checks/syncio_https.c 2017-11-06 11:35:39.376537746 +0100
++++ gwenhywfar-4.18.0/checks/syncio_https.c 2017-11-06 11:36:01.173317776 +0100
+@@ -33,7 +33,7 @@ static int check_syncio_https1() {
+ "ERROR in check_syncio_http1: Could not create socket io layer.\n");
+ return 2;
+ }
+- GWEN_SyncIo_Socket_SetAddress(sio, "devel.aqbanking.de");
++ GWEN_SyncIo_Socket_SetAddress(sio, "google.com");
+ GWEN_SyncIo_Socket_SetPort(sio, 443);
+
+ baseLayer=sio;
+@@ -82,7 +82,7 @@ static int check_syncio_https1() {
+ GWEN_DB_SetCharValue(db, GWEN_DB_FLAGS_OVERWRITE_VARS, "url", "/index.html");
+
+ db=GWEN_SyncIo_Http_GetDbHeaderOut(sio);
+- GWEN_DB_SetCharValue(db, GWEN_DB_FLAGS_OVERWRITE_VARS, "Host", "devel.aqbanking.de");
++ GWEN_DB_SetCharValue(db, GWEN_DB_FLAGS_OVERWRITE_VARS, "Host", "google.com");
+ GWEN_DB_SetIntValue(db, GWEN_DB_FLAGS_OVERWRITE_VARS, "Content-length", 0);
+ GWEN_DB_SetCharValue(db, GWEN_DB_FLAGS_OVERWRITE_VARS, "Connection", "close");
+
diff --git a/community/gwenhywfar/libintl.patch b/community/gwenhywfar/libintl.patch
new file mode 100644
index 0000000000..fd1cb5e6fe
--- /dev/null
+++ b/community/gwenhywfar/libintl.patch
@@ -0,0 +1,12 @@
+diff -upr gwenhywfar-4.15.3.orig/configure.ac gwenhywfar-4.15.3/configure.ac
+--- gwenhywfar-4.15.3.orig/configure.ac 2017-02-13 19:31:48.741133005 +0100
++++ gwenhywfar-4.15.3/configure.ac 2017-02-13 19:31:56.051144524 +0100
+@@ -734,7 +734,7 @@ if test "$OS_TYPE" != "windows"; then
+ oldlibs="$LIBS"
+ LIBS=""
+ AC_SEARCH_LIBS(gettext, intl, [], [HAVE_I18N="no"])
+- i18n_libs="$LIBS"
++ i18n_libs="$LIBS -lintl"
+ LIBS="$oldlibs"
+ else
+ i18n_libs="-lintl"