aboutsummaryrefslogtreecommitdiffstats
path: root/community/gwenhywfar
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2018-05-30 12:59:09 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2018-05-30 13:38:31 +0200
commita18864353865fca2b9813338181ac73596bef837 (patch)
treed49f1a8bfe16a47d1c0144fdfd0beba3b42c42ee /community/gwenhywfar
parentaf000ceb424d71d72d091338b96912fa4fed1c3f (diff)
downloadaports-a18864353865fca2b9813338181ac73596bef837.tar.bz2
aports-a18864353865fca2b9813338181ac73596bef837.tar.xz
community/gwenhywfar: fix tests
devel.aqbanking.de is no longer up. Send requests to google.com instead.
Diffstat (limited to 'community/gwenhywfar')
-rw-r--r--community/gwenhywfar/APKBUILD4
-rw-r--r--community/gwenhywfar/fix-tests.patch18
2 files changed, 16 insertions, 6 deletions
diff --git a/community/gwenhywfar/APKBUILD b/community/gwenhywfar/APKBUILD
index b071c93b95..6f5f33a633 100644
--- a/community/gwenhywfar/APKBUILD
+++ b/community/gwenhywfar/APKBUILD
@@ -3,7 +3,7 @@
pkgname=gwenhywfar
pkgver=4.18.0
_pkgrel=206
-pkgrel=0
+pkgrel=1
pkgdesc="Multi-platform helper library"
url="https://www.aquamaniac.de/"
arch="all"
@@ -55,4 +55,4 @@ package() {
sha512sums="3225a6eb06c8a0e53433b0cbac75818521664f2449905847747a4808d54ffaf3dfe597e71666accea28f5fc69f582f0e35942b128c7c96e788eed6e03ab894b4 gwenhywfar-4.18.0.tar.gz
fcccf5aa3872f4327205c3c77c5e1b88fbce89d6fe45330f72a38c207b7f6166ca486e70636119a9c16447a3c09e3bad97ed7a1cc5f06db53939f510e2c19cca libintl.patch
-62a127684b5d0900edf3f78b884285e63ea43d076b03c265cb59834e915fb68be61601bd54a6c991b20e793d511a5826fde22312e3fe3b2686d993cf32dd3869 fix-tests.patch"
+c877b91cd7e680f27b416563df67bf4834064672a021031d31bb597214b362068610de89d05ec2dc44336f02090546b9e6b80ea3758c8bf3974e8be7d5b4971d fix-tests.patch"
diff --git a/community/gwenhywfar/fix-tests.patch b/community/gwenhywfar/fix-tests.patch
index 00051f551b..a440b94170 100644
--- a/community/gwenhywfar/fix-tests.patch
+++ b/community/gwenhywfar/fix-tests.patch
@@ -1,8 +1,18 @@
-Port 443 is not open on devel.aqbanking.de connect to google.com instead.
-
+diff -upr gwenhywfar-4.18.0.orig/checks/syncio_http.c gwenhywfar-4.18.0/checks/syncio_http.c
+--- gwenhywfar-4.18.0.orig/checks/syncio_http.c 2014-07-23 22:28:23.000000000 +0200
++++ gwenhywfar-4.18.0/checks/syncio_http.c 2018-05-30 12:57:41.174981614 +0200
+@@ -32,7 +32,7 @@ static int check_syncio_http1() {
+ "ERROR in check_syncio_http1: Could not create socket io layer.\n");
+ return 2;
+ }
+- GWEN_SyncIo_Socket_SetAddress(sio, "devel.aqbanking.de");
++ GWEN_SyncIo_Socket_SetAddress(sio, "google.com");
+ GWEN_SyncIo_Socket_SetPort(sio, 80);
+
+ baseLayer=sio;
diff -upr gwenhywfar-4.18.0.orig/checks/syncio_https.c gwenhywfar-4.18.0/checks/syncio_https.c
---- gwenhywfar-4.18.0.orig/checks/syncio_https.c 2017-11-06 11:35:39.376537746 +0100
-+++ gwenhywfar-4.18.0/checks/syncio_https.c 2017-11-06 11:36:01.173317776 +0100
+--- gwenhywfar-4.18.0.orig/checks/syncio_https.c 2014-07-23 22:28:23.000000000 +0200
++++ gwenhywfar-4.18.0/checks/syncio_https.c 2018-05-30 12:57:14.844906364 +0200
@@ -33,7 +33,7 @@ static int check_syncio_https1() {
"ERROR in check_syncio_http1: Could not create socket io layer.\n");
return 2;