aboutsummaryrefslogtreecommitdiffstats
path: root/community/gwsocket
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-12-07 17:36:42 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-12-07 17:39:39 +0000
commit966df77a53c984ae30e5624d2d8d23e4830055c9 (patch)
tree7f79b1dc563f50799ea6bb4119707e1a368e5c42 /community/gwsocket
parent753b75a523a375cf0f32e14ada700b99d4ac8302 (diff)
downloadaports-966df77a53c984ae30e5624d2d8d23e4830055c9.tar.bz2
aports-966df77a53c984ae30e5624d2d8d23e4830055c9.tar.xz
community/gwsocket: modernize and add simple check
Add a simple test as upstream doesn't provide a test suite.
Diffstat (limited to 'community/gwsocket')
-rw-r--r--community/gwsocket/APKBUILD19
1 files changed, 10 insertions, 9 deletions
diff --git a/community/gwsocket/APKBUILD b/community/gwsocket/APKBUILD
index 613fd504ad..b0b053d398 100644
--- a/community/gwsocket/APKBUILD
+++ b/community/gwsocket/APKBUILD
@@ -2,19 +2,18 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=gwsocket
pkgver=0.2
-pkgrel=0
+pkgrel=1
pkgdesc="A simple, standalone, language-agnostic, RFC6455 compliant WebSocket Server"
url="http://gwsocket.io"
arch="all"
license="MIT"
-depends=""
makedepends="autoconf automake"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/allinurl/$pkgname/archive/v$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
prepare() {
- default_prepare || return 1
+ default_prepare
cd "$builddir"
autoreconf -fiv
@@ -28,16 +27,18 @@ build() {
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
- --localstatedir=/var \
- || return 1
- make || return 1
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ ./gwsocket --version > /dev/null
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
}
-md5sums="49e6f5392d7a2d0d6ca505d3b35beac2 gwsocket-0.2.tar.gz"
-sha256sums="cafb0cbde1d8b366c74c1602a8d2e1bde054834aa5c618cfad5603a871ae4082 gwsocket-0.2.tar.gz"
sha512sums="074676e8df80b3250be041e0f9225e6a5ba59eb8ecad9b95cd2b11038e52bc0a462144fbc302eb9b7816f38a23b12b4d9a7e949dce206fcb19938adeb5f4feb2 gwsocket-0.2.tar.gz"