aboutsummaryrefslogtreecommitdiffstats
path: root/community/httpry
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2016-11-08 14:02:02 +0000
committerJakub Jirutka <jakub@jirutka.cz>2016-11-19 20:33:01 +0100
commitb7cd8301eb95065cf94dc6c0206a15e83e1f3d00 (patch)
tree28a7e98d09dd6954a4429b1373ba1c9dbf792a44 /community/httpry
parent7d76142e2553403ea684f063199173b38a684a77 (diff)
downloadaports-b7cd8301eb95065cf94dc6c0206a15e83e1f3d00.tar.bz2
aports-b7cd8301eb95065cf94dc6c0206a15e83e1f3d00.tar.xz
community/httpry: move from unmaintained
Diffstat (limited to 'community/httpry')
-rw-r--r--community/httpry/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/community/httpry/APKBUILD b/community/httpry/APKBUILD
new file mode 100644
index 0000000000..11de97e4f5
--- /dev/null
+++ b/community/httpry/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=httpry
+pkgver=0.1.8
+pkgrel=0
+pkgdesc="A packet sniffer designed for HTTP traffic"
+url="http://dumpsterventures.com/jason/httpry/"
+arch="all"
+license="GPL2"
+makedepends="libpcap-dev"
+subpackages="$pkgname-doc"
+source="http://dumpsterventures.com/jason/httpry/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ install -m755 -D "$builddir"/$pkgname \
+ "$pkgdir"/usr/sbin/$pkgname || return 1
+ install -m644 -D "$builddir"/$pkgname.1 \
+ "$pkgdir"/usr/share/man/man1/$pkgname.1 || return 1
+}
+
+md5sums="212a03b32c3e3668f5890f8779a86ded httpry-0.1.8.tar.gz"
+sha256sums="ef53454f895f68005f7b9ab634d1b433c4df839eacea9109e4ee48d4296fb613 httpry-0.1.8.tar.gz"
+sha512sums="28d9fc37229e8b47711227762134e5b6e81bde0a44947f2e527771da2d042ba7e7c38b1ec205808a9e444e1235c91932ba16df4a31cc3d739c6474b25e149636 httpry-0.1.8.tar.gz"