aboutsummaryrefslogtreecommitdiffstats
path: root/community/i3lock
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2018-03-11 14:45:08 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2018-03-11 14:45:08 +0100
commit9909fb3da400f745c275f998e5071d93d0f341ec (patch)
treee309d32b0eb1529ff84e8d3581912e8c7efd51d0 /community/i3lock
parentca513f3f7ebc0d441f2d7089b909b2c0068fd708 (diff)
downloadaports-9909fb3da400f745c275f998e5071d93d0f341ec.tar.bz2
aports-9909fb3da400f745c275f998e5071d93d0f341ec.tar.xz
community/i3lock: move from main
Diffstat (limited to 'community/i3lock')
-rw-r--r--community/i3lock/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/community/i3lock/APKBUILD b/community/i3lock/APKBUILD
new file mode 100644
index 0000000000..a9460c7dd4
--- /dev/null
+++ b/community/i3lock/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Johannes Matheis <jomat+alpinebuild@jmt.gr>
+# Maintainer: Johannes Matheis <jomat+alpinebuild@jmt.gr>
+pkgname=i3lock
+pkgver=2.10
+pkgrel=0
+pkgdesc="An improved screenlocker based upon XCB and PAM"
+url="https://i3wm.org/i3lock/"
+arch="all"
+license="MIT"
+depends="xkeyboard-config"
+makedepends="libev-dev cairo-dev linux-pam-dev libxkbcommon-dev xcb-util-image-dev"
+subpackages="$pkgname-doc"
+source="$url/$pkgname-$pkgver.tar.bz2"
+builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ default_prepare
+
+ cd "$builddir"
+
+ # Fix ticket FS#31544, sed line taken from gentoo
+ sed -i -e 's:login:base-auth:g' i3lock.pam
+}
+
+build() {
+ cd "$builddir"
+ make
+}
+
+check() {
+ cd "$builddir"
+ ./i3lock -v
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ install -m755 -d "$pkgdir/usr/share/man/man1/"
+ install -m644 $pkgname.1 "$pkgdir/usr/share/man/man1/"
+}
+
+sha512sums="ea865b202668212b58d0b97d0263171847e1bd0c529e2fd3d26c15ef253861b9a8357ff2efaa6a4f342c4d0d1ab03bc00f95f4d4008760ec8e0767ac29195517 i3lock-2.10.tar.bz2"