aboutsummaryrefslogtreecommitdiffstats
path: root/community/ioping
diff options
context:
space:
mode:
authorTuan M. Hoang <tmhoang@flatglobe.org>2017-05-14 17:45:27 -0400
committerNatanael Copa <ncopa@alpinelinux.org>2017-05-16 13:09:04 +0000
commitc8c6c8ca8706f1f32b35cf452e25b994b76bed55 (patch)
tree05901c95aae17aa31f5bf365243d8e41766fb32a /community/ioping
parentab98989df46cbd8e37628f3b9394f33ebbc4a53a (diff)
downloadaports-c8c6c8ca8706f1f32b35cf452e25b994b76bed55.tar.bz2
aports-c8c6c8ca8706f1f32b35cf452e25b994b76bed55.tar.xz
community/ioping: fix bug s390x builder
since s390x builder is lxc, the host kernel returns EINVAL when fadvice() is called with POSIX_FADV_DONTNEED. Passing -C to ioping allows check() to run. Temp fix for 3.6.
Diffstat (limited to 'community/ioping')
-rw-r--r--community/ioping/APKBUILD1
1 files changed, 1 insertions, 0 deletions
diff --git a/community/ioping/APKBUILD b/community/ioping/APKBUILD
index fdef79fd48..442e8fc281 100644
--- a/community/ioping/APKBUILD
+++ b/community/ioping/APKBUILD
@@ -18,6 +18,7 @@ _builddir="$srcdir"/$pkgname-$pkgver
prepare() {
local i
cd "$_builddir"
+ [ "$CARCH" = "s390x" ] && sed -i -e 's@./$(BINARY)@./$(BINARY) -C@g' Makefile
for i in $source; do
case $i in
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;