aboutsummaryrefslogtreecommitdiffstats
path: root/community/irrlicht
diff options
context:
space:
mode:
authortmpfile <tmpfile@users.noreply.github.com>2017-05-14 14:52:38 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2017-06-09 15:06:08 +0000
commit291ea01edfec3cb7a7399ff02777128f873d1bab (patch)
tree94268b7cf52d9cbcea7e09419c20a8be87a480fd /community/irrlicht
parent312fdbda3fe84c751ac3747684fb3ec7f8788344 (diff)
downloadaports-291ea01edfec3cb7a7399ff02777128f873d1bab.tar.bz2
aports-291ea01edfec3cb7a7399ff02777128f873d1bab.tar.xz
community/irrlicht: modernize abuild
Diffstat (limited to 'community/irrlicht')
-rw-r--r--community/irrlicht/APKBUILD35
1 files changed, 8 insertions, 27 deletions
diff --git a/community/irrlicht/APKBUILD b/community/irrlicht/APKBUILD
index 2abd2bb82e..aee182f980 100644
--- a/community/irrlicht/APKBUILD
+++ b/community/irrlicht/APKBUILD
@@ -7,38 +7,27 @@ pkgdesc="High performance realtime 3D engine written in C++"
url="http://irrlicht.sourceforge.net"
arch="all"
license="ZLIB"
-depends=
+depends=""
makedepends="mesa-dev jpeg-dev bzip2 libpng-dev zlib-dev"
-install=""
subpackages="$pkgname-dev $pkgname-doc"
source="http://downloads.sourceforge.net/irrlicht/irrlicht-$pkgver.zip
irrlicht-1.8.3-mesa-10.x.patch
irrlicht-1.8.3-config.patch
irrlicht-1.8.3-sysctl.patch
-"
-_builddir="$srcdir"/$pkgname-$pkgver/
-
-prepare() {
- local i
- cd "$srcdir"/$pkgname-$pkgver/
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+ "
+builddir="$srcdir"/$pkgname-$pkgver/
build() {
- cd "$_builddir"/source/Irrlicht/
+ cd "$builddir"/source/Irrlicht/
export CXXFLAGS="$CXXFLAGS -std=gnu++98"
- make sharedlib || return 1
+ make sharedlib
#from arch pkgbuild: example build helper
ln -s libIrrlicht.so.$pkgver "$srcdir"/$pkgname-$pkgver/lib/Linux/libIrrlicht.so
}
package() {
- cd "$_builddir"
+ cd "$builddir"
mkdir -p "$pkgdir"/usr/lib
mkdir -p "$pkgdir"/usr/share/licenses/$pkgname
@@ -50,22 +39,14 @@ package() {
#from arch pkgbuild: install docs
cp -r doc/* "$pkgdir"/usr/share/doc/$pkgname
- install -m755 "$_builddir"/lib/Linux/libIrrlicht.so.$pkgver "$pkgdir"/usr/lib
+ install -m755 "$builddir"/lib/Linux/libIrrlicht.so.$pkgver "$pkgdir"/usr/lib
cd "$pkgdir"/usr/lib
ln -s libIrrlicht.so.$pkgver libIrrlicht.so
ln -s libIrrlicht.so.$pkgver libIrrlicht.so.1.8
- install -m644 "$_builddir"/include/* "$pkgdir"/usr/include/$pkgname
+ install -m644 "$builddir"/include/* "$pkgdir"/usr/include/$pkgname
}
-md5sums="d13dbdad9609741de02023627ee51078 irrlicht-1.8.3.zip
-b83f74be3507b9a0488ac15892456ac9 irrlicht-1.8.3-mesa-10.x.patch
-f3a3616ae60d19a44c58e71d70e52186 irrlicht-1.8.3-config.patch
-eb2edf8959d587f590e978b4e93b3663 irrlicht-1.8.3-sysctl.patch"
-sha256sums="9e7be44277bf2004d73580a8585e7bd3c9ce9a3c801691e4f4aed030ac68931c irrlicht-1.8.3.zip
-d17e8084cb5b458aef85a136b6366e07e615b8dcca18fd7f66a988886d7ab750 irrlicht-1.8.3-mesa-10.x.patch
-67393d31171dfdaf34dc0874c9bece9c25d58589f4532e23487a20b5c33c514e irrlicht-1.8.3-config.patch
-71a372624332d8c72c215565e1d66da1ff8eb85cefdbe4f0c8c949fb6aa74e8d irrlicht-1.8.3-sysctl.patch"
sha512sums="ec76449afb83d778a322636590bde698e276772981a79944bbb2fcc45bdfd2aada10f6fb038f53aed89a2fe0d022af771fc824ed9734ff8c542b967c0a1c2b55 irrlicht-1.8.3.zip
44c16419c07597ba6d06d66057fbe2ab86e7b02b5dcdf458678b4ea87f6f721840da951ae4df59c983e1da83abdbe45f82e44a6a311bd42eb94d93dfd5aa437c irrlicht-1.8.3-mesa-10.x.patch
8bb80040b90bc3d4b8d3f9c5c3f39f3cc2d09fef663338e0994788bc1cd9254b9e7465ac2b344d4532a83c2dc27a8bed9ef5bc26824ef91e4e0159f6db2216e1 irrlicht-1.8.3-config.patch