aboutsummaryrefslogtreecommitdiffstats
path: root/community/john
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2018-04-23 16:02:21 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2018-04-23 16:02:26 +0000
commit005258ba5fea6986fc41ceba2d5f6485ce1f98d9 (patch)
tree37c8bd91f76cbf1a9292ae3be0465e95f8bafb35 /community/john
parent603593148a2d42089fcfdafed112a401dc5eb4cd (diff)
downloadaports-005258ba5fea6986fc41ceba2d5f6485ce1f98d9.tar.bz2
aports-005258ba5fea6986fc41ceba2d5f6485ce1f98d9.tar.xz
community/john: fixed typo for unshadow, updated APKBUILD
Diffstat (limited to 'community/john')
-rw-r--r--community/john/APKBUILD13
1 files changed, 6 insertions, 7 deletions
diff --git a/community/john/APKBUILD b/community/john/APKBUILD
index e382526fee..6204cac50a 100644
--- a/community/john/APKBUILD
+++ b/community/john/APKBUILD
@@ -4,7 +4,7 @@
pkgname=john
pkgver=1.8.0
_pkgrel=jumbo-1
-pkgrel=9
+pkgrel=10
pkgdesc="John the Ripper password cracker"
url="http://www.openwall.com/john"
arch="x86_64 armhf ppc64le"
@@ -12,7 +12,6 @@ license="GPL-2.0"
depends="nss"
options="!strip"
makedepends="libpcap-dev libressl-dev gmp-dev yasm-dev zlib-dev"
-install=""
subpackages="$pkgname-doc
$pkgname-scripts-py:py:noarch
$pkgname-scripts-perl:perl:noarch
@@ -36,7 +35,7 @@ build() {
export OPENSSL_LIBS="-lssl -lcrypto"
./configure \
--disable-openmp
- make || return 1
+ make
}
package() {
@@ -51,14 +50,14 @@ package() {
rm "$pkgdir"/usr/share/doc/$pkgname/LICENSE*
local john_bins="john calc_stat genmkvpwd mkvcalcproba relbench
- tgtsnarf raw2dyna"
+ tgtsnarf john-mailer raw2dyna"
for bin in ${john_bins}; do
install -Dm755 run/${bin} "$pkgdir"/usr/bin
done
local john_links="hccap2john keepass2john mozilla2john pdf2john
pfx2john pwsafe2john racf2john rar2john ssh2john
- unafs unique unsahdow undrop zip2john"
+ unafs unique unshadow undrop zip2john"
for link in ${john_links}; do
ln -s john "$pkgdir"/usr/bin/${link}
done
@@ -112,7 +111,7 @@ bashcomp() {
cd "$builddir"
install -Dm644 run/john.bash_completion \
- "$subpkgdir"/usr/share/bash-completion/completions/$pkgname || return 1
+ "$subpkgdir"/usr/share/bash-completion/completions/$pkgname
}
zshcomp() {
@@ -122,7 +121,7 @@ zshcomp() {
cd "$builddir"
install -Dm644 run/john.zsh_completion \
- "$subpkgdir"/usr/share/zsh/site-functions/$pkgname || return 1
+ "$subpkgdir"/usr/share/zsh/site-functions/$pkgname
}
jumbo() {