aboutsummaryrefslogtreecommitdiffstats
path: root/community/john
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2016-11-01 06:19:43 +0000
committerTimo Teräs <timo.teras@iki.fi>2016-11-01 06:20:08 +0000
commit44c3a3f6c1325a9d1e6c1fd31102e3dc93fa193b (patch)
tree8e82a935cf4ad89447fdc47aadc3e2f2a64bfb55 /community/john
parent2641df97b0a4c4bfde4eabd4dbe9ce6aa7f9ab4d (diff)
downloadaports-44c3a3f6c1325a9d1e6c1fd31102e3dc93fa193b.tar.bz2
aports-44c3a3f6c1325a9d1e6c1fd31102e3dc93fa193b.tar.xz
community/john: fix whatespace, subpkg arch setting
Diffstat (limited to 'community/john')
-rw-r--r--community/john/APKBUILD125
1 files changed, 62 insertions, 63 deletions
diff --git a/community/john/APKBUILD b/community/john/APKBUILD
index 41755072b8..52bd797e05 100644
--- a/community/john/APKBUILD
+++ b/community/john/APKBUILD
@@ -3,7 +3,7 @@
pkgname=john
pkgver=1.8.0
_pkgrel=jumbo-1
-pkgrel=4
+pkgrel=5
pkgdesc="John the Ripper password cracker"
url="http://www.openwall.com/john"
arch="x86_64 armhf"
@@ -12,19 +12,21 @@ depends="nss"
options="!strip"
makedepends="libpcap-dev libressl-dev gmp-dev yasm-dev zlib-dev"
install=""
-subpackages="$pkgname-doc \
- $pkgname-scripts-py:py \
- $pkgname-scripts-perl:perl \
- $pkgname-scripts-ruby:ruby \
- $pkgname-misc \
- $pkgname-zsh-completion:zshcomp \
- $pkgname-bash-completion:bashcomp"
+subpackages="$pkgname-doc
+ $pkgname-scripts-py:py:noarch
+ $pkgname-scripts-perl:perl:noarch
+ $pkgname-scripts-ruby:ruby:noarch
+ $pkgname-misc::noarch
+ $pkgname-zsh-completion:zshcomp:noarch
+ $pkgname-bash-completion:bashcomp:noarch
+ "
source="$pkgname-$pkgver.tar.gz::https://github.com/magnumripper/JohnTheRipper/archive/$pkgver-$_pkgrel.tar.gz
- truecrypt_fmt_plug.patch
- params-h.patch
- gcc5-support.patch
- libressl.patch
- "
+ truecrypt_fmt_plug.patch
+ params-h.patch
+ gcc5-support.patch
+ libressl.patch
+ "
+
builddir="$srcdir/JohnTheRipper-$pkgver-$_pkgrel"
build() {
cd "$builddir"/src
@@ -48,7 +50,7 @@ package() {
local john_bins="john calc_stat genmkvpwd mkvcalcproba \
relbench tgtsnarf raw2dyna"
for bin in $(echo ${john_bins}); do
- install -Dm755 run/${bin} -t "${pkgdir}/usr/bin"
+ install -Dm755 run/${bin} -t "${pkgdir}/usr/bin"
done
cd "${pkgdir}/usr/bin"
@@ -63,9 +65,9 @@ package() {
py() {
pkgdesc="Python Scripts for John the Ripper"
- arch=noarch
depends="python2 libxml2 libgsf"
install_if="$pkgname=$pkgver-r$pkgrel"
+
cd "$builddir"
local john_scripts="1password2john.py ecryptfs2john.py \
kwallet2john.py openssl2john.py 7z2john.py efs2john.py \
@@ -88,90 +90,87 @@ py() {
perl() {
pkgdesc="Perl Scripts for John the Ripper"
- arch=noarch
depends="perl"
install_if="$pkgname=$pkgver-r$pkgrel"
+
cd "$builddir"
local john_scripts="aix2john.pl ios7tojohn.pl \
lion2john-alt.pl pass_gen.pl sap2john.pl \
cisco2john.pl ldif2john.pl lion2john.pl \
- radius2john.pl sha-dump.pl hextoraw.pl \
+ radius2john.pl sha-dump.pl hextoraw.pl \
leet.pl netntlm.pl rexgen2rules.pl \
sha-test.pl benchmark-unify"
for john_script in $(echo ${john_scripts}); do
install -D -m755 run/${john_script} \
"$subpkgdir"/usr/share/john
- done
+ done
}
ruby() {
- pkgdesc="Ruby Scripts for John the Ripper"
- arch=noarch
- depends="ruby"
- install_if="$pkgname=$pkgver-r$pkgrel"
- cd "$builddir"
- local john_scripts="genincstats.rb"
- for john_script in $(echo ${john_scripts}); do
- install -D -m755 run/${john_script} \
- "$subpkgdir"/usr/share/john
- done
+ pkgdesc="Ruby Scripts for John the Ripper"
+ depends="ruby"
+ install_if="$pkgname=$pkgver-r$pkgrel"
+
+ cd "$builddir"
+ local john_scripts="genincstats.rb"
+ for john_script in $(echo ${john_scripts}); do
+ install -D -m755 run/${john_script} \
+ "$subpkgdir"/usr/share/john
+ done
}
misc() {
- pkgdesc="Misc tools for John the Ripper: password list and charset files"
- arch=noarch
- install_if="$pkgname=$pkgver-r$pkgrel"
+ pkgdesc="Misc tools for John the Ripper: password list and charset files"
+ install_if="$pkgname=$pkgver-r$pkgrel"
+
cd "$builddir"
mkdir -p ${subpkgdir}/usr/share/john/kernels/
local john_pwdfiles="password.lst dictionary.rfc2865 stats"
local john_conffiles="dumb16.conf dumb32.conf dynamic.conf \
- dynamic_flat_sse_formats.conf regex_alphabets.conf \
- repeats16.conf repeats32.conf"
- local john_chrfiles="lowernum.chr alnum.chr upper.chr lower.chr \
- alpha.chr ascii.chr latin1.chr lanman.chr \
- lowerspace.chr digits.chr lm_ascii.chr utf8.chr \
- uppernum.chr makechr alnumspace.chr"
-
- for john_pwdfiles in $(echo ${john_pwdfiles}); do
- install -D -m644 run/${john_pwdfiles} \
- "$subpkgdir"/usr/share/john
- done
-
- for john_conffiles in $(echo ${john_conffiles}); do
- install -D -m644 run/${john_conffiles} \
- "$subpkgdir"/usr/share/john
- done
-
-
- for john_chrfiles in $(echo ${john_chrfiles}); do
- install -D -m644 run/${john_chrfiles} \
- "$subpkgdir"/usr/share/john
- done
+ dynamic_flat_sse_formats.conf regex_alphabets.conf \
+ repeats16.conf repeats32.conf"
+ local john_chrfiles="lowernum.chr alnum.chr upper.chr lower.chr \
+ alpha.chr ascii.chr latin1.chr lanman.chr \
+ lowerspace.chr digits.chr lm_ascii.chr utf8.chr \
+ uppernum.chr makechr alnumspace.chr"
+
+ for john_pwdfiles in $(echo ${john_pwdfiles}); do
+ install -D -m644 run/${john_pwdfiles} \
+ "$subpkgdir"/usr/share/john
+ done
+
+ for john_conffiles in $(echo ${john_conffiles}); do
+ install -D -m644 run/${john_conffiles} \
+ "$subpkgdir"/usr/share/john
+ done
+
+ for john_chrfiles in $(echo ${john_chrfiles}); do
+ install -D -m644 run/${john_chrfiles} \
+ "$subpkgdir"/usr/share/john
+ done
}
bashcomp() {
- depends=""
- pkgdesc="Bash completions for $pkgname"
- install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
- arch="noarch"
+ depends=""
+ pkgdesc="Bash completions for $pkgname"
+ install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
+
cd "$builddir"
- install -Dm644 run/john.bash_completion \
- "$subpkgdir"/usr/share/bash-completion/completions/$pkgname || return 1
+ install -Dm644 run/john.bash_completion \
+ "$subpkgdir"/usr/share/bash-completion/completions/$pkgname || return 1
}
zshcomp() {
depends=""
pkgdesc="Zsh completions for $pkgname"
install_if="$pkgname=$pkgver-r$pkgrel zsh"
- arch="noarch"
+
cd "$builddir"
- install -Dm644 run/john.zsh_completion \
+ install -Dm644 run/john.zsh_completion \
"$subpkgdir"/usr/share/zsh/site-functions/$pkgname || return 1
}
-
-
md5sums="2e80ec877e78d0c6ce72febb8844e0e2 john-1.8.0.tar.gz
e6e158d946783b14e1109bd96d54bb64 truecrypt_fmt_plug.patch
d6ab104062b9ce84b172ad7ecdd08226 params-h.patch