aboutsummaryrefslogtreecommitdiffstats
path: root/community/keepalived
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-10-03 19:13:56 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-10-03 19:32:10 +0200
commitb9a6cfefb662391ecb6fabb69dcce4608bc5205f (patch)
treefc35540066e3c5bd5e86becfad5945262f01a7c1 /community/keepalived
parentea4d894393d01824eddbbb29ac711ec65d7c32af (diff)
downloadaports-b9a6cfefb662391ecb6fabb69dcce4608bc5205f.tar.bz2
aports-b9a6cfefb662391ecb6fabb69dcce4608bc5205f.tar.xz
community/keepalived: remove explicit returns
Diffstat (limited to 'community/keepalived')
-rw-r--r--community/keepalived/APKBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/community/keepalived/APKBUILD b/community/keepalived/APKBUILD
index 698e796260..78ec4532d0 100644
--- a/community/keepalived/APKBUILD
+++ b/community/keepalived/APKBUILD
@@ -22,17 +22,17 @@ source="http://www.keepalived.org/software/$pkgname-$pkgver.tar.gz
builddir="$srcdir/$pkgname-$pkgver"
prepare() {
- default_prepare || return 1
+ default_prepare
# The build scripts are somehow broken, so we must regenerate them.
- autoreconf -fiv || return 1
+ autoreconf -fiv
cp -ar "$builddir" "$builddir-snmp"
}
build() {
cd "$builddir-snmp"
- _build --enable-snmp || return 1
+ _build --enable-snmp
cd "$builddir"
_build
@@ -49,18 +49,18 @@ _build() {
--with-kernel-dir=/usr/include/linux \
--enable-vrrp \
--enable-sha1 \
- $@ || return 1
- make || return 1
+ $@
+ make
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
local f; for f in AUTHOR CONTRIBUTORS ChangeLog README INSTALL TODO \
genhash/README genhash/AUTHOR genhash/ChangeLog; do
- install -m644 -D $f "$pkgdir"/usr/share/doc/$pkgname/$f || return 1
+ install -m644 -D $f "$pkgdir"/usr/share/doc/$pkgname/$f
done
install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
@@ -75,7 +75,7 @@ common() {
mkdir -p "$subpkgdir"/usr
- mv "$pkgdir"/etc "$subpkgdir"/ || return 1
+ mv "$pkgdir"/etc "$subpkgdir"/
mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
}
@@ -85,7 +85,7 @@ snmp() {
cd "$builddir-snmp"
- install -m700 -D bin/keepalived "$subpkgdir"/usr/sbin/keepalived || return 1
+ install -m700 -D bin/keepalived "$subpkgdir"/usr/sbin/keepalived
mkdir -p "$subpkgdir"/usr/share/snmp/mibs
install -m644 doc/*-MIB "$subpkgdir"/usr/share/snmp/mibs/