aboutsummaryrefslogtreecommitdiffstats
path: root/community/knot
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-04-12 12:46:20 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-04-12 12:47:11 +0000
commit895fce1fe10e22042ff039c4be35e81cccd1cae6 (patch)
tree1f9dbd08c9417ccf06c9f63d1c5fa522b0cd6021 /community/knot
parent442fbd8bc0d3b26b3e6d54684c800c6d1b1eab0a (diff)
downloadaports-895fce1fe10e22042ff039c4be35e81cccd1cae6.tar.bz2
aports-895fce1fe10e22042ff039c4be35e81cccd1cae6.tar.xz
community/knot: upgrade to 2.4.3, modernize APKBUILD
Diffstat (limited to 'community/knot')
-rw-r--r--community/knot/APKBUILD23
1 files changed, 11 insertions, 12 deletions
diff --git a/community/knot/APKBUILD b/community/knot/APKBUILD
index cb1487479a..e3e33248eb 100644
--- a/community/knot/APKBUILD
+++ b/community/knot/APKBUILD
@@ -4,7 +4,7 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=knot
-pkgver=2.4.2
+pkgver=2.4.3
pkgrel=0
pkgdesc="An high-performance authoritative-only DNS server"
url="https://www.knot-dns.cz"
@@ -17,6 +17,7 @@ makedepends="$depends_dev m4 bison flex perl jansson-dev libtool"
install="$pkgname.pre-install $pkgname.post-install knot.post-upgrade"
pkgusers="knot"
pkggroups="knot"
+options="!check"
subpackages="$pkgname-libs
$pkgname-utils
$pkgname-bash-completion:bashcomp:noarch
@@ -31,7 +32,7 @@ source="https://secure.nic.cz/files/knot-dns/$pkgname-$pkgver.tar.xz
builddir="$srcdir/$pkgname-$pkgver"
prepare() {
- default_prepare || return 1
+ default_prepare
cd "$builddir"
# Make sure embedded LMDB library is not used.
@@ -48,25 +49,23 @@ build() {
--libexecdir=/usr/lib/knot \
--with-rundir=/run/knot \
--with-storage=/var/lib/knot \
- --disable-silent-rules \
- || return 1
- make || return 1
- #make check || return 1
+ --disable-silent-rules
+ make
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
rm -Rf "$pkgdir"/run
- chown $pkgusers:$pkggroups "$pkgdir"/var/lib/$pkgname || return 1
- chmod 750 "$pkgdir"/var/lib/$pkgname || return 1
+ chown $pkgusers:$pkggroups "$pkgdir"/var/lib/$pkgname
+ chmod 750 "$pkgdir"/var/lib/$pkgname
install -Dm 644 "$srcdir"/knotd.confd \
- "$pkgdir"/etc/conf.d/knotd || return 1
+ "$pkgdir"/etc/conf.d/knotd
install -Dm 755 "$srcdir"/knotd.initd \
- "$pkgdir"/etc/init.d/knotd || return 1
+ "$pkgdir"/etc/init.d/knotd
}
libs() {
@@ -105,6 +104,6 @@ zshcomp() {
"$subpkgdir"/usr/share/zsh/site-functions/_keymgr
}
-sha512sums="8e3f6ea1cf951f090977d26ed555a8e228416e2b7c7f86eae1b5d744099203effb1df6c664076547ef3e820fe8af15b370651edbf8b846b3c0707f4cd2faa4f2 knot-2.4.2.tar.xz
+sha512sums="b10b739673484c108748a247238acc8d58b7dc78bdb659d22903c9eeebd0a8d042dd5fc85328b09fa22ffa7d0aa3fe1f108ba1bf0b8eafe9ea3a81118226fae8 knot-2.4.3.tar.xz
471d3c639a8235ba09491c99d36c0a4f1074d6055ccfd3807be02a30d3ed5bbe69a84f0414ea7810db6bbc1e38f5837108e5744fc59f949ed78a262a7de4597e knotd.confd
979f06a83dd4326920a682f8190319577faf904e0e379b3c55e0420eb43dcb55d86c6727015634fa0c2dff1dddac43bbd5a216ff04f217ad91d670eb899dbefa knotd.initd"