aboutsummaryrefslogtreecommitdiffstats
path: root/community/libcdr
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-23 18:41:40 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-23 18:41:40 +0000
commit4e3fbb7e5935fb930ab1b0f0f83084c9fd5dfdc6 (patch)
tree779ef98c5e9b133f4eedf1dea0ad287d6ba79c39 /community/libcdr
parenta60987858f2d31749aad004861f4896fa98c7816 (diff)
downloadaports-4e3fbb7e5935fb930ab1b0f0f83084c9fd5dfdc6.tar.bz2
aports-4e3fbb7e5935fb930ab1b0f0f83084c9fd5dfdc6.tar.xz
community/libcdr: modernize and add check
Diffstat (limited to 'community/libcdr')
-rw-r--r--community/libcdr/APKBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/community/libcdr/APKBUILD b/community/libcdr/APKBUILD
index a0d10c186b..a8c1dd9e5e 100644
--- a/community/libcdr/APKBUILD
+++ b/community/libcdr/APKBUILD
@@ -2,19 +2,17 @@
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=libcdr
pkgver=0.1.4
-pkgrel=0
+pkgrel=1
pkgdesc="Import filter and tools for Corel DRAW files"
url="https://wiki.documentfoundation.org/DLP/Libraries/libcdr"
arch="all"
license="MPL2"
-depends=""
depends_dev="boost-dev"
makedepends="$depends_dev doxygen icu-dev lcms2-dev zlib-dev librevenge-dev"
-install=""
subpackages="$pkgname-dev $pkgname-doc $pkgname-tools"
source="http://dev-www.libreoffice.org/src/$pkgname/$pkgname-$pkgver.tar.xz"
-builddir="$srcdir"/$pkgname-$pkgver
+builddir="$srcdir/$pkgname-$pkgver"
prepare() {
default_prepare
@@ -34,6 +32,11 @@ build() {
make
}
+check() {
+ cd "$builddir"
+ make check
+}
+
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install