aboutsummaryrefslogtreecommitdiffstats
path: root/community/libcec
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-11-03 07:31:42 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-11-03 08:53:46 +0000
commita8a266f81be2a75ff331764fd67ba7c852436a37 (patch)
tree94ed67186fbf6d204ef72c70c455474ae2bb8398 /community/libcec
parent1a2d26fef3d4997c23b0ddf35fbbd8e701112068 (diff)
downloadaports-a8a266f81be2a75ff331764fd67ba7c852436a37.tar.bz2
aports-a8a266f81be2a75ff331764fd67ba7c852436a37.tar.xz
community/{lockdev,libcec}: move from main
Diffstat (limited to 'community/libcec')
-rw-r--r--community/libcec/APKBUILD54
-rw-r--r--community/libcec/musl-fix.patch22
2 files changed, 76 insertions, 0 deletions
diff --git a/community/libcec/APKBUILD b/community/libcec/APKBUILD
new file mode 100644
index 0000000000..d127a9d841
--- /dev/null
+++ b/community/libcec/APKBUILD
@@ -0,0 +1,54 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=libcec
+pkgver=2.2.0
+pkgrel=1
+pkgdesc="libcec for the Pulse-Eight USB-CEC adapter"
+url="https://github.com/Pulse-Eight/libcec"
+arch="all"
+license="GPL"
+depends=""
+depends_dev="lockdev-dev eudev-dev"
+makedepends="$depends_dev autoconf automake libtool"
+install=""
+subpackages="$pkgname-dev"
+source="http://github.com/Pulse-Eight/libcec/archive/libcec-$pkgver.tar.gz
+ musl-fix.patch
+ "
+
+_builddir="$srcdir"/libcec-libcec-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./bootstrap || return 1
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="006df0d807d4b72bc6859e592c7a70eb libcec-2.2.0.tar.gz
+f735b18f2cb4f75aaa68a15407e233cd musl-fix.patch"
+sha256sums="fd4f47a18d6e0f4b9e6f5831280207ee2b2a5fc2741ae32ae09ad12a8aa52917 libcec-2.2.0.tar.gz
+f64edcdc316ffd0ea4310529bf7ba96072c757182201c382e4f9c791cf8efbe9 musl-fix.patch"
+sha512sums="7932a45e581e207aa651e9fe72450fda52b0441fb48e40e971a530f9d5d26b87e6446322393750d85bae223519dc2a73613352a3fe42939eff2c5f8863a09cd7 libcec-2.2.0.tar.gz
+ca81f243ca7245efbb5bea97209894b37316195ed14ab8687d6cc4d01dd121c16a245d5a95c6554903138f1f3f0a0be8602e8579474e64a618903737e4619136 musl-fix.patch"
diff --git a/community/libcec/musl-fix.patch b/community/libcec/musl-fix.patch
new file mode 100644
index 0000000000..c77e0e5d94
--- /dev/null
+++ b/community/libcec/musl-fix.patch
@@ -0,0 +1,22 @@
+--- libcec-libcec-2.1.3.orig/src/lib/platform/posix/serialport.cpp
++++ libcec-libcec-2.1.3/src/lib/platform/posix/serialport.cpp
+@@ -37,7 +37,6 @@
+ #include "lib/platform/util/baudrate.h"
+ #include "lib/platform/posix/os-socket.h"
+
+-#if defined(__APPLE__) || defined(__FreeBSD__)
+ #ifndef XCASE
+ #define XCASE 0
+ #endif
+@@ -47,10 +46,9 @@
+ #ifndef IUCLC
+ #define IUCLC 0
+ #endif
+-#else
++
+ #ifdef HAVE_LOCKDEV
+ #include <lockdev.h>
+-#endif
+ #endif
+
+ using namespace std;