aboutsummaryrefslogtreecommitdiffstats
path: root/community/libgweather
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-10-08 16:23:29 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-10-09 12:37:46 +0000
commitaef0f0212556536202a3f40fa831bfe9c80cefd6 (patch)
tree58d3e4aa17c9e3726eea4e53170fe34b827dfb0d /community/libgweather
parent023fe494c20a122f8892784cb910ecab6a917211 (diff)
downloadaports-aef0f0212556536202a3f40fa831bfe9c80cefd6.tar.bz2
aports-aef0f0212556536202a3f40fa831bfe9c80cefd6.tar.xz
community/libgweather: upgrade to 3.28.2
Diffstat (limited to 'community/libgweather')
-rw-r--r--community/libgweather/APKBUILD35
1 files changed, 20 insertions, 15 deletions
diff --git a/community/libgweather/APKBUILD b/community/libgweather/APKBUILD
index 0c2f0db978..d2542b0999 100644
--- a/community/libgweather/APKBUILD
+++ b/community/libgweather/APKBUILD
@@ -1,37 +1,42 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libgweather
-pkgver=3.26.0
+pkgver=3.28.2
pkgrel=0
pkgdesc="GNOME weather library"
url="https://www.gnome.org/"
arch="all"
license="LGPL"
depends="tzdata"
-makedepends="gtk+3.0-dev libsoup-dev libxml2-dev
- glib-dev geocode-glib-dev gobject-introspection-dev
- libxml2-utils gtk-doc py-six"
+makedepends="gtk+3.0-dev libsoup-dev libxml2-dev
+ glib-dev geocode-glib-dev gobject-introspection-dev
+ libxml2-utils gtk-doc py-six glade-dev meson ninja"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+checkdepends="gsettings-desktop-schemas"
source="https://download.gnome.org/sources/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.xz"
builddir="${srcdir}/${pkgname}-${pkgver}"
build() {
- cd "$builddir"
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
+ mkdir -p "$builddir"/build
+ cd "$builddir"/build
+ meson \
--prefix=/usr \
- --sysconfdir=/etc
- make
+ --buildtype=release \
+ --sysconfdir=/etc \
+ -Dgtk_doc=true \
+ ..
+ ninja
}
check() {
- cd "$builddir"
- make check
+ cd "$builddir"/build
+ ninja test
}
+
package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install
+ cd "$builddir"/build
+ export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
+ DESTDIR="$pkgdir" ninja install
}
-sha512sums="46fcc8319861237f908218b223102217591d731803093727a159912cefbd82017e1e064535d785e7f4ee6d227b47aff3240a14396fb9dc06ab26343720473606 libgweather-3.26.0.tar.xz"
+sha512sums="b92716f5f7d7789e12f8fd66ad23de35e921d493ebf4618f68cc669e1b9be8ae6fbb929ee9a027fefe0ad9550f0d39c8647aa0d7ad7e35f1980bee8c9de19b4e libgweather-3.28.2.tar.xz"