aboutsummaryrefslogtreecommitdiffstats
path: root/community/libkeyfinder
diff options
context:
space:
mode:
authorJean-Louis Fuchs <ganwell@fangorn.ch>2017-07-16 14:13:07 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2017-07-17 07:16:17 +0000
commit4ec12bc907c61b760a5e050ece50b9896068e8ca (patch)
tree7da64137b33f505e74902d67eb40999a7d2d99aa /community/libkeyfinder
parent6cd63892c8438be7e16de83fac1bb931087ab7e1 (diff)
downloadaports-4ec12bc907c61b760a5e050ece50b9896068e8ca.tar.bz2
aports-4ec12bc907c61b760a5e050ece50b9896068e8ca.tar.xz
community/libkeyfinder: move from testing
Diffstat (limited to 'community/libkeyfinder')
-rw-r--r--community/libkeyfinder/APKBUILD41
-rw-r--r--community/libkeyfinder/add-missing-include-for-ppc64le.patch13
-rw-r--r--community/libkeyfinder/alpine-settings-to-pro.patch28
3 files changed, 82 insertions, 0 deletions
diff --git a/community/libkeyfinder/APKBUILD b/community/libkeyfinder/APKBUILD
new file mode 100644
index 0000000000..703194734e
--- /dev/null
+++ b/community/libkeyfinder/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Jean-Louis Fuchs <ganwell@fangorn.ch>
+# Maintainer: Jean-Louis Fuchs <ganwell@fangorn.ch>
+pkgname=libkeyfinder
+pkgver=2.2.1
+pkgrel=2
+pkgdesc="Musical key detection for digital audio"
+url="http://www.ibrahimshaath.co.uk/keyfinder/"
+arch="all"
+license="GPL"
+# Its just using qmake
+makedepends="qt-dev fftw-dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="libkeyfinder-$pkgver.tar.gz::https://github.com/ibsh/libKeyFinder/archive/v$pkgver.tar.gz
+ alpine-settings-to-pro.patch
+ add-missing-include-for-ppc64le.patch"
+builddir="$srcdir/libKeyFinder-$pkgver"
+
+build() {
+ cd "$builddir"
+ qmake PREFIX=/usr
+ make
+}
+
+package() {
+ cd "$builddir"
+ make INSTALL_ROOT="$pkgdir" install
+ install -Dm644 "$builddir"/README.md \
+ "$pkgdir"/usr/share/doc/$pkgname/README.md
+}
+
+check() {
+ cd "$builddir/tests"
+ ln -s "$builddir" keyfinder
+ qmake
+ make
+ LD_LIBRARY_PATH="$builddir" ./tests
+}
+
+sha512sums="62790681e34e8513ac185396c9f76981238da3136a9bd646b197a1e7032d6d612e90157be9dd13700bbeb98085ee3d628ae847716e0091490cd6c3839bf2c25d libkeyfinder-2.2.1.tar.gz
+580c968da0d24126d92b09cc4a970bb898fe020f2b9a9232d80ef63be8d3f90e618ea0b2f66ccde174a51dcf7160dfd62ab3b9428bf0ae6b11608b7dd7aede23 alpine-settings-to-pro.patch
+6292619361970bb85bb41a9ea94f12b2d70ca2b6d1957d9e27c56dbc3eaf55c49eb3616c0cbcd9b5855197f66c67064a8461c693e90a037e1019f0cd5da90587 add-missing-include-for-ppc64le.patch"
diff --git a/community/libkeyfinder/add-missing-include-for-ppc64le.patch b/community/libkeyfinder/add-missing-include-for-ppc64le.patch
new file mode 100644
index 0000000000..3ef2851f86
--- /dev/null
+++ b/community/libkeyfinder/add-missing-include-for-ppc64le.patch
@@ -0,0 +1,13 @@
+--- libKeyFinder-2.2.1/fftadapter.cpp
++++ libKeyFinder-2.2.1/fftadapter.cpp
+@@ -25,6 +25,10 @@
+ #include <cmath>
+ #include <fftw3.h>
+
++#ifdef __powerpc64__
++#include <string.h>
++#endif
++
+ namespace KeyFinder {
+
+ std::mutex fftwPlanMutex;
diff --git a/community/libkeyfinder/alpine-settings-to-pro.patch b/community/libkeyfinder/alpine-settings-to-pro.patch
new file mode 100644
index 0000000000..36cfe6d937
--- /dev/null
+++ b/community/libkeyfinder/alpine-settings-to-pro.patch
@@ -0,0 +1,28 @@
+diff -ur a/LibKeyFinder.pro b/LibKeyFinder.pro
+--- a/LibKeyFinder.pro 2017-03-12 23:41:10.000000000 +0100
++++ b/LibKeyFinder.pro 2017-03-23 16:49:06.236738498 +0100
+@@ -30,7 +30,8 @@
+ VERSION = 2.2.0
+
+ CONFIG += c++11
+-QMAKE_CXXFLAGS += -std=c++11
++QMAKE_CXXFLAGS_RELEASE -= -O2
++QMAKE_CXXFLAGS += -std=c++11 -Os -fomit-frame-pointer
+
+ DEFINES += LIBKEYFINDER_LIBRARY
+
+diff -ur a/tests/tests.pro b/tests/tests.pro
+--- a/tests/tests.pro 2017-03-23 16:47:17.280248215 +0100
++++ b/tests/tests.pro 2017-03-23 16:48:28.386799769 +0100
+@@ -27,8 +27,9 @@
+ CONFIG -= qt
+
+ CONFIG += c++11
+-LIBS += -stdlib=libc++
+-QMAKE_CXXFLAGS += -std=c++11 -stdlib=libc++
++LIBS += -L..
++QMAKE_CXXFLAGS_RELEASE -= -O2
++QMAKE_CXXFLAGS += -std=c++11 -Os -fomit-frame-pointer
+
+ LIBS += -lkeyfinder
+