aboutsummaryrefslogtreecommitdiffstats
path: root/community/liboauth
diff options
context:
space:
mode:
authortmpfile <tmpfile@users.noreply.github.com>2017-09-06 16:12:03 -0300
committerTimo Teräs <timo.teras@iki.fi>2017-09-07 08:02:36 +0000
commit202a101b82921dc5eba7ead4a9210a9bee8f5c49 (patch)
tree13bfdc2b94d11a07514da5ce2ea0f4609b13c0c5 /community/liboauth
parent9b9078146ef5a64c53e4df613a2ba1dc1d6199be (diff)
downloadaports-202a101b82921dc5eba7ead4a9210a9bee8f5c49.tar.bz2
aports-202a101b82921dc5eba7ead4a9210a9bee8f5c49.tar.xz
community/liboauth: move autoreconf to prepare() and modernize
Diffstat (limited to 'community/liboauth')
-rw-r--r--community/liboauth/APKBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/community/liboauth/APKBUILD b/community/liboauth/APKBUILD
index 47cda6771c..eb609324c7 100644
--- a/community/liboauth/APKBUILD
+++ b/community/liboauth/APKBUILD
@@ -8,15 +8,17 @@ arch="all"
license="MIT"
depends=""
makedepends="nss-dev curl-dev automake autoconf libtool"
-install=""
subpackages="$pkgname-dev $pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/x42/liboauth/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
-builddir="$srcdir"/liboauth-$pkgver
+prepare() {
+ cd "$builddir"
+ autoreconf -vif
+}
build() {
cd "$builddir"
- autoreconf -vif || return 1
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -26,16 +28,13 @@ build() {
--infodir=/usr/share/info \
--localstatedir=/var \
--disable-static \
- --enable-nss \
- || return 1
- make || return 1
+ --enable-nss
+ make
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
}
-md5sums="a334455fe331672cd20c131e61e86df7 liboauth-1.0.3.tar.gz"
-sha256sums="bbe73b9f576fab0deefadb242c069f2f8bfa4068c738b7666ccd01381502c854 liboauth-1.0.3.tar.gz"
sha512sums="94976f9e1ae451b3b312664b8d3e7858913673ef783539df4a033a55ffa05e56410a3dab0cfd8a1d9e839bd6d7fedd3258ac8819c7d3cf1357a862174bf49a71 liboauth-1.0.3.tar.gz"