aboutsummaryrefslogtreecommitdiffstats
path: root/community/liborcus
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-08-13 08:24:19 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-08-13 10:34:23 +0000
commit5bc414bb50fe0a1a38b9300bec1d5cb67b1e13ee (patch)
tree30d3a400952e5faf9a81d7b27eed0a25bdefcef7 /community/liborcus
parent8f91cfd3873005a7e0ebfd5609292a09982b55c3 (diff)
downloadaports-5bc414bb50fe0a1a38b9300bec1d5cb67b1e13ee.tar.bz2
aports-5bc414bb50fe0a1a38b9300bec1d5cb67b1e13ee.tar.xz
community/liborcus: rebuild against boost 1.67
Diffstat (limited to 'community/liborcus')
-rw-r--r--community/liborcus/APKBUILD9
-rw-r--r--community/liborcus/boost-1.67.patch50
2 files changed, 56 insertions, 3 deletions
diff --git a/community/liborcus/APKBUILD b/community/liborcus/APKBUILD
index 5b83cc6c47..3c2e67d460 100644
--- a/community/liborcus/APKBUILD
+++ b/community/liborcus/APKBUILD
@@ -2,14 +2,16 @@
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=liborcus
pkgver=0.13.4
-pkgrel=0
+pkgrel=1
pkgdesc="Library for processing spreadsheet documents"
url="https://gitlab.com/orcus/orcus"
arch="all"
license="MPL-2.0"
makedepends="$depends_dev boost-dev mdds-dev libixion-dev zlib-dev libixion-dev"
subpackages="$pkgname-dev"
-source="http://kohei.us/files/orcus/src/liborcus-$pkgver.tar.xz"
+source="http://kohei.us/files/orcus/src/liborcus-$pkgver.tar.xz
+ boost-1.67.patch
+ "
builddir="$srcdir/liborcus-$pkgver"
build() {
@@ -35,4 +37,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="f00b49c41eb1898c37d8d42e59f9004f46b5f849b9d60ac9c5033232d1e5065ff3de160e79f5a88983bf64f86e283b6d1d406a24e776aa6ff7b8acec324ccd4b liborcus-0.13.4.tar.xz"
+sha512sums="f00b49c41eb1898c37d8d42e59f9004f46b5f849b9d60ac9c5033232d1e5065ff3de160e79f5a88983bf64f86e283b6d1d406a24e776aa6ff7b8acec324ccd4b liborcus-0.13.4.tar.xz
+4a1817f70a955caa213af3ff6542b6faf0db3261406ab60b87dfc4637ab29fb1e6eb6e402911e6d5e22e29e8eb049b26c03160c8a6b802a9b842f0b8311097ba boost-1.67.patch"
diff --git a/community/liborcus/boost-1.67.patch b/community/liborcus/boost-1.67.patch
new file mode 100644
index 0000000000..eb51fa9cd4
--- /dev/null
+++ b/community/liborcus/boost-1.67.patch
@@ -0,0 +1,50 @@
+From f7485813af8e50f88c77312fb29b7bb489a0a17d Mon Sep 17 00:00:00 2001
+From: Adam Majer <amajer@suse.de>
+Date: Wed, 23 May 2018 10:45:56 +0200
+Subject: [PATCH] Fix build with Boost 1.67
+
+Boost:DateTime that no longer accepts non-integer types.
+In the past, these types were implicitly cast down to integer
+values. Now this requires explicit cast.
+
+https://svn.boost.org/trac10/ticket/11168
+
+This fixes #60
+---
+ src/spreadsheet/sheet.cpp | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/src/spreadsheet/sheet.cpp b/src/spreadsheet/sheet.cpp
+index 7df1aedb..33b372ad 100644
+--- a/src/spreadsheet/sheet.cpp
++++ b/src/spreadsheet/sheet.cpp
+@@ -289,7 +289,7 @@ void sheet::set_date_time(row_t row, col_t col, int year, int month, int day, in
+
+ double days_since_epoch = (d - origin).days();
+
+- double ms = second * 1000000.0;
++ long ms = second * 1000000.0;
+
+ posix_time::time_duration t(
+ posix_time::hours(hour) +
+@@ -606,7 +606,7 @@ date_time_t sheet::get_date_time(row_t row, col_t col) const
+ if (time_fraction)
+ {
+ // Convert a fraction day to microseconds.
+- double ms = time_fraction * 24.0 * 60.0 * 60.0 * 1000000.0;
++ long long ms = time_fraction * 24.0 * 60.0 * 60.0 * 1000000.0;
+ posix_time::time_duration td = posix_time::microsec(ms);
+
+ hours = td.hours();
+@@ -615,7 +615,7 @@ date_time_t sheet::get_date_time(row_t row, col_t col) const
+
+ td -= posix_time::hours(hours);
+ td -= posix_time::minutes(minutes);
+- td -= posix_time::seconds(seconds);
++ td -= posix_time::seconds((long)seconds);
+
+ ms = td.total_microseconds(); // remaining microseconds.
+
+--
+2.18.0
+