aboutsummaryrefslogtreecommitdiffstats
path: root/community/libpeas
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2018-01-27 15:59:40 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2018-01-27 16:00:32 +0000
commit73dc9eda8622e8f570d143fcd9fcadd822006553 (patch)
tree43c199e94cbb30e4da42b8605888e9050c3cbccc /community/libpeas
parent1333b0e3d879d92b242b712761a4b6daae3d3124 (diff)
downloadaports-73dc9eda8622e8f570d143fcd9fcadd822006553.tar.bz2
aports-73dc9eda8622e8f570d143fcd9fcadd822006553.tar.xz
community/libpeas: upgrade to 1.22.0 and modernize
Diffstat (limited to 'community/libpeas')
-rw-r--r--community/libpeas/APKBUILD20
1 files changed, 8 insertions, 12 deletions
diff --git a/community/libpeas/APKBUILD b/community/libpeas/APKBUILD
index 854e6c2341..bae7ea5387 100644
--- a/community/libpeas/APKBUILD
+++ b/community/libpeas/APKBUILD
@@ -1,19 +1,16 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=libpeas
-pkgver=1.20.0
-pkgrel=1
+pkgver=1.22.0
+pkgrel=0
pkgdesc="GObject-based plugin system"
url="https://wiki.gnome.org/Projects/Libpeas"
arch="all"
license="LGPL"
-depends=""
-depends_dev=""
makedepends="$depends_dev glib-dev gobject-introspection-dev intltool gtk+3.0-dev py-gobject3-dev python3-dev"
-install=""
subpackages="$pkgname-dev $pkgname-doc $pkgname-python3:py3"
-source="https://download.gnome.org/sources/libpeas/1.20/libpeas-$pkgver.tar.xz"
-builddir="$srcdir/libpeas-$pkgver"
+source="https://download.gnome.org/sources/libpeas/1.22/libpeas-$pkgver.tar.xz"
+builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
@@ -24,14 +21,13 @@ build() {
--sysconfdir=/etc \
--mandir=/usr/share/man \
--localstatedir=/var \
- --disable-python2 \
- || return 1
- make || return 1
+ --disable-python2
+ make
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
}
py3() {
@@ -40,4 +36,4 @@ py3() {
mv "$pkgdir"/usr/lib/libpeas-1.0/loaders/libpython3loader.* "$subpkgdir"/usr/lib/libpeas-1.0/loaders/
}
-sha512sums="b3ddebf65e1a76493b5cd5150f60c13597c90398eea16c002e51d25449a595f7591bd0ccd1214ca3a8cbce724eb10f38a316e8c95092442034c048bc95cfdbf4 libpeas-1.20.0.tar.xz"
+sha512sums="9c1da1d4b5688c0f4d0647f3519dbfbed94c8921091057aaef0e41bf5ed3f8faf04a49ce9e4eea3fd7bf4ac4dfa1727d76a5f6dae2a4f52228d4c8c74b420c91 libpeas-1.22.0.tar.xz"