aboutsummaryrefslogtreecommitdiffstats
path: root/community/libqmi
diff options
context:
space:
mode:
authorStuart Cardall <developer@it-offshore.co.uk>2017-03-23 04:42:07 +0000
committerJakub Jirutka <jakub@jirutka.cz>2017-03-23 14:29:08 +0100
commit025d0415292fffbde7141779d591f62f83445209 (patch)
treefdb3c3f9153ca5d1ecbdcc983974543d7ab9df52 /community/libqmi
parent56b9865f811a534a1b37238f5983045ebac42519 (diff)
downloadaports-025d0415292fffbde7141779d591f62f83445209.tar.bz2
aports-025d0415292fffbde7141779d591f62f83445209.tar.xz
community/libqmi: update to 1.18.0
Diffstat (limited to 'community/libqmi')
-rw-r--r--community/libqmi/APKBUILD7
-rw-r--r--community/libqmi/musl-compat-canonicalize_file_name.patch3
2 files changed, 6 insertions, 4 deletions
diff --git a/community/libqmi/APKBUILD b/community/libqmi/APKBUILD
index 232c284fd4..fc11162979 100644
--- a/community/libqmi/APKBUILD
+++ b/community/libqmi/APKBUILD
@@ -1,13 +1,14 @@
# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
pkgname=libqmi
-pkgver=1.17.901
+pkgver=1.18.0
pkgrel=0
pkgdesc="QMI modem protocol helper library"
url="http://www.freedesktop.org/wiki/Software/libqmi"
arch="all"
license="GPL2"
makedepends="gtk-doc python2 glib-dev libgudev-dev linux-headers"
+options="!check"
subpackages="$pkgname-dev $pkgname-doc"
source="https://www.freedesktop.org/software/$pkgname/$pkgname-$pkgver.tar.xz
musl-compat-canonicalize_file_name.patch
@@ -32,5 +33,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="31db491460a43f9f1cbbfe28c2133edbcf51b9762a5c1f81f9c0c8db7878e563269646de15e56eeedcda632016d5250f67cf4395ec8a5085d720fa5ac0ae78c7 libqmi-1.17.901.tar.xz
-57e6e6f142119a9ad5074475f9f18845271d6582ec485422ebe29f00f8a6da49f6770d9b8ff9fb97d1b6367a93766e3ebe4d05b415ad65713a093434fd962d19 musl-compat-canonicalize_file_name.patch"
+sha512sums="3890501fa2299ce5ac8fda732363e39738c95ffb153708d8f727e88c082014018463c569a0d9666385f6394d060ec41052dec400f3f6c733e78748ca7ee56b76 libqmi-1.18.0.tar.xz
+f7a660cc391d0821b681790b57a8b450dff2b0540af816cfa0b674100d97a79399307050e41f6302f2755c90e5dee448ff82806e00e6b42b50f984cfea263ac8 musl-compat-canonicalize_file_name.patch"
diff --git a/community/libqmi/musl-compat-canonicalize_file_name.patch b/community/libqmi/musl-compat-canonicalize_file_name.patch
index 3ed1baf57e..15b3849374 100644
--- a/community/libqmi/musl-compat-canonicalize_file_name.patch
+++ b/community/libqmi/musl-compat-canonicalize_file_name.patch
@@ -1,6 +1,6 @@
--- libqmi-1.17.901/src/libqmi-glib/qmi-utils.h
+++ libqmi-1.17.901/src/libqmi-glib/qmi-utils.h.new
-@@ -29,6 +29,23 @@
+@@ -29,6 +29,24 @@
#error "Only <libqmi-glib.h> can be included directly."
#endif
@@ -8,6 +8,7 @@
+#include <limits.h>
+#include <string.h>
+#include <stdlib.h>
++#include <stdio.h>
+static char * canonicalize_file_name(const char *path)
+{
+ char buf[PATH_MAX] = { };