aboutsummaryrefslogtreecommitdiffstats
path: root/community/libqmi
diff options
context:
space:
mode:
authorStuart Cardall <developer@it-offshore.co.uk>2017-01-22 19:50:08 +0000
committerJakub Jirutka <jakub@jirutka.cz>2017-01-25 02:59:39 +0100
commitb3b80fb78439380914f7c732bf65d87c696bf291 (patch)
tree72deb6538679cb63bca058a4df9b73963d574780 /community/libqmi
parent0c11527a80630dbc08689317a3e7003a8baea442 (diff)
downloadaports-b3b80fb78439380914f7c732bf65d87c696bf291.tar.bz2
aports-b3b80fb78439380914f7c732bf65d87c696bf291.tar.xz
community/libqmi: update to 1.17.900
Diffstat (limited to 'community/libqmi')
-rw-r--r--community/libqmi/APKBUILD21
-rw-r--r--community/libqmi/fix-unknown-fd_set.patch10
2 files changed, 23 insertions, 8 deletions
diff --git a/community/libqmi/APKBUILD b/community/libqmi/APKBUILD
index 6ac206f0d7..7dde4c04eb 100644
--- a/community/libqmi/APKBUILD
+++ b/community/libqmi/APKBUILD
@@ -1,16 +1,18 @@
# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
pkgname=libqmi
-pkgver=1.16.0
+pkgver=1.17.900
pkgrel=0
pkgdesc="QMI modem protocol helper library"
url="http://www.freedesktop.org/wiki/Software/libqmi"
arch="all"
license="GPL2"
-makedepends="gtk-doc python2 glib-dev"
+makedepends="gtk-doc python2 glib-dev libgudev-dev linux-headers"
subpackages="$pkgname-dev $pkgname-doc"
-source="https://www.freedesktop.org/software/$pkgname/$pkgname-$pkgver.tar.xz"
-builddir="$srcdir"/$pkgname-$pkgver
+source="https://www.freedesktop.org/software/$pkgname/$pkgname-$pkgver.tar.xz
+ fix-unknown-fd_set.patch
+ "
+builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
@@ -20,7 +22,7 @@ build() {
--localstatedir=/var \
--disable-static \
--enable-more-warnings=yes \
- || return 1
+ || return 1
make || return 1
make check || return 1
}
@@ -30,6 +32,9 @@ package() {
make DESTDIR="$pkgdir" install
}
-md5sums="4970c110f160b33637a3515004c637b2 libqmi-1.16.0.tar.xz"
-sha256sums="7ab6bb47fd23bf4d3fa17424e40ea5552d08b19e5ee4f125f21f316c8086ba2a libqmi-1.16.0.tar.xz"
-sha512sums="e8ac10b72a15ab3d102ab5dd45ed2960f552d37c291b7ef2818f41d5a46121a5c25e60bb549f96d4982468607a11f33866632c13b0454c5cbe0d61aa95992996 libqmi-1.16.0.tar.xz"
+md5sums="2589a45756484122b1045cf08adc1dea libqmi-1.17.900.tar.xz
+c5fd4bda7a7c510b1a733e6fdf66c570 fix-unknown-fd_set.patch"
+sha256sums="4a4aeff7fcb56248ed0c82bdf14cec251ca0d332310775bd178408f52d11e7fb libqmi-1.17.900.tar.xz
+9636ee40cc22bfcdc6a6f4702fce105e8c7c4d482f7affac7957cf5b6f7754ed fix-unknown-fd_set.patch"
+sha512sums="a6f8bc1a276e69a8c1fc5f11a5693bdb4746c5c682dde5aaa7f7b1bab14adf5602467c9979c3393aa4e3fa4bbde79a4fcf9cda34c03dbe5c8c34b4d85de67194 libqmi-1.17.900.tar.xz
+10b99ec481fc90fe424bf2393e4ae1764b116465ec65cd01122ff95d7b6ebf811a3a1e5eb6e3fc328f1f8a65da59886c885b483c2ffeee5e4809d34d01e13b64 fix-unknown-fd_set.patch"
diff --git a/community/libqmi/fix-unknown-fd_set.patch b/community/libqmi/fix-unknown-fd_set.patch
new file mode 100644
index 0000000000..03e21d4dda
--- /dev/null
+++ b/community/libqmi/fix-unknown-fd_set.patch
@@ -0,0 +1,10 @@
+--- libqmi-1.17.900/utils/swi-update.c
++++ libqmi-1.17.900/utils/swi-update.c.new
+@@ -40,6 +40,7 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <sys/stat.h>
++#include <sys/select.h>
+ #include <termios.h>
+ #include <unistd.h>
+