aboutsummaryrefslogtreecommitdiffstats
path: root/community/libreoffice
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2017-02-09 14:53:27 +0000
committerTimo Teräs <timo.teras@iki.fi>2017-02-09 15:51:34 +0000
commitc4eabe8910112097afa9e6672192570d8a78ae54 (patch)
treea94707b9d3f68ea2973b5d1a482ba44a87ea5701 /community/libreoffice
parentaeacc77dcfc4962b8e0af6ad9b2e17400742474e (diff)
downloadaports-c4eabe8910112097afa9e6672192570d8a78ae54.tar.bz2
aports-c4eabe8910112097afa9e6672192570d8a78ae54.tar.xz
community/libreoffice: enable java support
Based on work by Jens Staal, but modified to not include extra fonts, rebased on top of new libreoffice version and added sdk subpackages.
Diffstat (limited to 'community/libreoffice')
-rw-r--r--community/libreoffice/APKBUILD89
1 files changed, 65 insertions, 24 deletions
diff --git a/community/libreoffice/APKBUILD b/community/libreoffice/APKBUILD
index 609d18d845..320ba10385 100644
--- a/community/libreoffice/APKBUILD
+++ b/community/libreoffice/APKBUILD
@@ -1,8 +1,9 @@
+# Contributor: Jens Staal <staal1978@gmail.com>
# Contributor: Timo Teräs <timo.teras@iki.fi>
-# Maintainer:
+# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=libreoffice
pkgver=5.3.0.3
-pkgrel=0
+pkgrel=1
pkgdesc="LibreOffice - Meta package for the full office suite"
url="http://www.libreoffice.org/"
arch="all"
@@ -16,15 +17,16 @@ depends_dev="cups-dev libjpeg-turbo-dev boost-dev clucene-dev libe-book-dev icu-
gconf-dev bluez-dev gstreamer1-dev gst-plugins-base1-dev gtk+2.0-dev
poppler-dev cairo-dev hyphen-dev mythes-dev python3-dev harfbuzz-dev
libfreehand-dev libodfgen-dev libcdr-dev libzmf-dev libstaroffice-dev
- liborcus-dev"
+ liborcus-dev openjdk8 apache-ant junit"
makedepends="$depends_dev autoconf automake tar coreutils findutils ucpp gperf
- bison flex zip perl perl-archive-zip sed libxml2-utils doxygen"
+ bison flex zip perl perl-archive-zip sed tar libxml2-utils doxygen paxmark"
# GNU sed is needed for in i18npool/CustomTarget_localedata.mk
install=""
subpackages="$pkgname-base $pkgname-calc $pkgname-common $pkgname-draw
- $pkgname-gnome $pkgname-impress $pkgname-math
+ $pkgname-gnome $pkgname-impress $pkgname-math $pkgname-connector-postgres $pkgname-writer
+ $pkgname-sdk $pkgname-sdk-doc:sdk_doc libreofficekit"
+depends="$pkgname-base $pkgname-calc $pkgname-common $pkgname-draw $pkgname-impress $pkgname-math
$pkgname-connector-postgres $pkgname-writer libreofficekit"
-depends="$subpackages"
_addsrcurl="http://dev-www.libreoffice.org/src"
case $pkgver in
*.*.*.*) _v=${pkgver%.*};;
@@ -36,6 +38,24 @@ source="http://download.documentfoundation.org/libreoffice/src/${_v}/libreoffice
http://download.documentfoundation.org/libreoffice/src/${_v}/libreoffice-dictionaries-$pkgver.tar.xz
http://download.documentfoundation.org/libreoffice/src/${_v}/libreoffice-translations-$pkgver.tar.xz
$_addsrcurl/86b1daaa438f5a7bea9a52d7b9799ac0-xmlsec1-1.2.23.tar.gz
+ $_addsrcurl/17410483b5b5f267aa18b7e00b65e6e0-hsqldb_1_8_0.zip
+ $_addsrcurl/commons-logging-1.2-src.tar.gz
+ $_addsrcurl/beeca87be45ec87d241ddd0e1bad80c1-bsh-2.0b6-src.zip
+ $_addsrcurl/39bb3fcea1514f1369fcfc87542390fd-sacjava-1.3.zip
+ $_addsrcurl/eeb2c7ddf0d302fba4bfc6e97eac9624-libbase-1.1.6.zip
+ $_addsrcurl/d8bd5eed178db6e2b18eeed243f85aa8-flute-1.1.6.zip
+ $_addsrcurl/97b2d4dba862397f446b217e2b623e71-libloader-1.1.6.zip
+ $_addsrcurl/ace6ab49184e329db254e454a010f56d-libxml-1.1.7.zip
+ $_addsrcurl/3404ab6b1792ae5f16bbd603bd1e1d03-libformula-1.1.7.zip
+ $_addsrcurl/3bdf40c0d199af31923e900d082ca2dd-libfonts-1.1.6.zip
+ $_addsrcurl/8ce2fcd72becf06c41f7201d15373ed9-librepository-1.1.6.zip
+ $_addsrcurl/f94d9870737518e3b597f9265f4e9803-libserializer-1.1.6.zip
+ $_addsrcurl/db60e4fde8dd6d6807523deb71ee34dc-liblayout-0.2.10.zip
+ $_addsrcurl/ba2930200c9f019c2d93a8c88c651a0f-flow-engine-0.9.4.zip
+ $_addsrcurl/798b2ffdc8bcfe7bca2cf92b62caf685-rhino1_5R5.zip
+ $_addsrcurl/35c94d2df8893241173de1d16b6034c0-swingExSrc.zip
+ http://dev-www.libreoffice.org/extern/185d60944ea767075d27247c3162b3bc-unowinreg.dll
+
linux-musl.patch
fix-execinfo.patch
fix-includes.patch
@@ -218,7 +238,10 @@ build() {
--with-external-hyph-dir=/usr/share/hyphen \
--with-external-tar="$srcdir" \
--with-lang="$languages" \
- --without-java \
+ --with-jdk-home="/usr/lib/jvm/default-jvm" \
+ --with-ant-home="/usr/share/java/apache-ant" \
+ --without-system-jars \
+ --without-junit \
--without-fonts \
--without-system-sane \
--without-myspell-dicts \
@@ -248,7 +271,7 @@ _split() {
for i in $(grep -v ^%dir $builddir/file-lists/${1}_list.txt | sort -u); do
dirname="$(dirname $i)"
[ -d "$subpkgdir/$dirname" ] || install -dm755 "$subpkgdir/$dirname"
- mv "$pkgdir"/../all/"$i" "$subpkgdir"/"$i"
+ mv "$pkgdir"/../all/"$i" "$subpkgdir"/"$i" || return 1
done
}
@@ -267,7 +290,10 @@ calc() {
common() {
pkgdesc="LibreOffice - Common files"
depends="libreoffice-lang-en_us"
- _split common
+ _split common || return 1
+ paxmark -m \
+ "$subpkgdir"/usr/lib/libreoffice/program/soffice.bin \
+ "$subpkgdir"/usr/lib/libreoffice/program/unopkg.bin
}
draw() {
@@ -290,7 +316,7 @@ impress() {
libreofficekit() {
mkdir -p "$subpkgdir"/usr/include
- mv "$builddir"/include/LibreOfficeKit "$subpkgdir"/usr/include || return 1
+ cp -a "$builddir"/include/LibreOfficeKit "$subpkgdir"/usr/include || return 1
}
math() {
@@ -311,24 +337,39 @@ writer() {
_split writer
}
-md5sums="204c492a0b5e58dd0be9788c74a364ab libreoffice-5.3.0.3.tar.xz
-f9e3e741b929c5af19b1321569537b68 libreoffice-dictionaries-5.3.0.3.tar.xz
-6ad27f9d0348010afca53167c9e350cb libreoffice-translations-5.3.0.3.tar.xz
-86b1daaa438f5a7bea9a52d7b9799ac0 86b1daaa438f5a7bea9a52d7b9799ac0-xmlsec1-1.2.23.tar.gz
-04064db9416656b525c4f59f04dfa7e9 linux-musl.patch
-1cff63a520d1b037edddf1b4de4799dc fix-execinfo.patch
-c6fc4d38ef1bab69f3570a0d087b4c52 fix-includes.patch"
-sha256sums="04b9215e1c4b8c7ce2d79b8e322bff8d097426a2d103476cf237cfd42262556e libreoffice-5.3.0.3.tar.xz
-c5c9463548286d8dbb33af722e13d01a2b753ea6103b51c9f2929d8d2079ddf5 libreoffice-dictionaries-5.3.0.3.tar.xz
-4321a57fba1012b30eae6e629f18d4139395fd5751af381dc87e31e084fca1d1 libreoffice-translations-5.3.0.3.tar.xz
-41d463d16c9894cd3317098d027c038039c6d896b9cbb9bad9c4e29959e10e9f 86b1daaa438f5a7bea9a52d7b9799ac0-xmlsec1-1.2.23.tar.gz
-7ad68a55826ca7b985cce28743c3f6196d469ab8e4aa4ac3d6072005053e16a5 linux-musl.patch
-7171dfa651a7ee81b4e13a9fd9131428d9a65af138cac4cb428ae6c3e4bcb1f3 fix-execinfo.patch
-51052d983eeea85d8d71385e4eeda61b6a8746854fe046b9a91e12c013d9ed89 fix-includes.patch"
+sdk() {
+ pkgdesc="LibreOffice - SDK"
+ depends="libreoffice-common"
+ _split sdk
+}
+
+sdk_doc() {
+ pkgdesc="LibreOffice - SDK documentation"
+ depends="libreoffice-common"
+ _split sdk_doc
+}
+
sha512sums="06cf8a59c2b08f6aaf5012347aeae482ecccc4587c67fc6d3f267572f236999ec6fe1f1290926830ebe5631c705cf4e938b65a5765e99556c8d19178e0fece45 libreoffice-5.3.0.3.tar.xz
a007a43850bd4e0a40462b32980215c51c17d1b27f071a0d30c89fe70d4047be8f1be7a283b0a4019b91bd0c1e2eb62bbc317b7039889114002e48b43650074f libreoffice-dictionaries-5.3.0.3.tar.xz
569e5450802201a34011e9e98d2de32676b5aac98abffa2241ab1aa23ade60baf222687a60e931fa28a55421f49b4c97f26169348172f272b3bf88aff9ed9457 libreoffice-translations-5.3.0.3.tar.xz
20b0c0ba517c764fcd32165254ae6dcdda8fb72ca3279dbfcf42d899e91d380b78d9be3b1c3d32910eaad5544a4fc51218e32579b10e6b6639338a7bd8b1ddc5 86b1daaa438f5a7bea9a52d7b9799ac0-xmlsec1-1.2.23.tar.gz
+a231eba4a1baca11766ef292ab45e302081115477fe23018652882923308856835cf8c9ecba61a5cf22543474ccef3136965d794a90c9e4e9e6dcc21f9af6e1a 17410483b5b5f267aa18b7e00b65e6e0-hsqldb_1_8_0.zip
+9f3761184950f2f13e85d8bc447709ab8be631dfd231b4f053f8147468db1bf71fb116ddba95e39f4afc4cf28c742e07d40c7a637f28004a60dc13935f9609f9 commons-logging-1.2-src.tar.gz
+a04eca6a57807358bd4f8d017a2eeaa58403ef51fab11fc46ab089113a0ff5f66aaa793d3fc57b484334cbf51ed388a90d8d72d1e5819c8248cc0113ac928a77 beeca87be45ec87d241ddd0e1bad80c1-bsh-2.0b6-src.zip
+a7c3044a0a7c67881f78eddc4b3faf05e29b20755a59cdbb9a0a49bd21be5aaa95d4ea5eaabdd6f005a421981fb7c55fee590d4c9592fe363ba27ae590652bd4 39bb3fcea1514f1369fcfc87542390fd-sacjava-1.3.zip
+9091d3628d9c75c068507537afc9e10bfb79c1abfd36ad697af3d592a1cc049ba6640f665bfc53cc520b6a26c21d70b0275106843444b441484c2178f2784743 eeb2c7ddf0d302fba4bfc6e97eac9624-libbase-1.1.6.zip
+71164f5e052db4fc16d1eb6ceb66d2b483d4912d874e371399047761e1d82e95d14288be5a7952c40f0ce39366f0706e726720e6e7171a00ce7bb55632cbf10c d8bd5eed178db6e2b18eeed243f85aa8-flute-1.1.6.zip
+17ba9d2c0376fb7326d53bb1e3796610176a1af426d1b9073b5f7cf06c93d865e585c495e75c52fb8e426d7c453e751356a9ca9a54dc821ddadb6c8160ed5ba6 97b2d4dba862397f446b217e2b623e71-libloader-1.1.6.zip
+58c1aa3965bf3a5f5d0facb67a5e42cec04e3f74e59cd7348ea2a9f6d9cafdce5552677c6b6d9c4cf2b31f52751695f2e53b2cee658e5f2eacb1393534a53c0e ace6ab49184e329db254e454a010f56d-libxml-1.1.7.zip
+9fe106bbdb55365f589246e5a0d10bbe9b35224132b66a1823dc6361633a67f2acc0e8c393dc7ed70d086858d16d242b8806b8b2184c98e3d20d0be85bed9c44 3404ab6b1792ae5f16bbd603bd1e1d03-libformula-1.1.7.zip
+8eaa9eed3bff16a16483d0754756c181089eb705ea34ded7f9f6db90a591cbce3f0551f28d097bd2f44de813cb818720c430e79e516939e0398b72bf4614f4cd 3bdf40c0d199af31923e900d082ca2dd-libfonts-1.1.6.zip
+12ab17a4db3f7c834b21e59ff6f6f6456630d8626db7fb908867b20204295d4fba8969e79a3694ca66cb24e9f0e5a0fa4b9d2d3f748691b7f93985f9e666ce5f 8ce2fcd72becf06c41f7201d15373ed9-librepository-1.1.6.zip
+c1a15ebbfe817ec79d4b3f1c97d096bf8511737d7d35d97302856ccfb3de14a1cd16bd31000415d9ab24bbd9ef770d37855cee4b819ff0e8fca2f2766920a114 f94d9870737518e3b597f9265f4e9803-libserializer-1.1.6.zip
+4476024e7f307617719714fbf0999409aa11d730bc316f833bb6627d1b83abb42460417be588c193ecb49d6b926dd1f411934d8a8abebe00a3e85c0047dad0a6 db60e4fde8dd6d6807523deb71ee34dc-liblayout-0.2.10.zip
+654d2408c11349c90ae7d80b0c1997ee831004bc4ee36a706a0d8a84617fd0f82a97c5b45ab2388d60085afaec59a02eada007a8a1e14c3b366cabd36b7607ec ba2930200c9f019c2d93a8c88c651a0f-flow-engine-0.9.4.zip
+ec5ae23c8fe2f5efc377f7a9665039afadf28b4d8f2791379296766a5fbc9a3bf7548f9b0e3b3b07762229ec733a92ccbb69791ee0318c9c6f78f8e847253d3f 798b2ffdc8bcfe7bca2cf92b62caf685-rhino1_5R5.zip
+4a48f1e32907fb2dee601cda3cd7a0d7198b2d51f2a572b647f1e93f901fd511eef3567676e52dfb1723a2cdfbc01f2015ca0bb22903b0bc1476dd618cc9aa8a 35c94d2df8893241173de1d16b6034c0-swingExSrc.zip
+854b8ae29b57b40ba6bb6ff66e723a0e8dad053fcc2849f0ad763cd8a31352f4aeba9636fd4e3f0f2a0cd985a6f49b4261b9ace68d6be821ed42cfa7a73eb13c 185d60944ea767075d27247c3162b3bc-unowinreg.dll
10a1ee056ebce41b2f6d3863b220f8529f70b7fd159ff2d36967ad96d9653166737db4ba865c10769c37afad553f59fb9629437c0d8a1afbbff963fc36dbbf1a linux-musl.patch
567123f990c4a47c2e4cebf99f3486150740015e647ca2b2521e606f3350fc55ceda6c7ac031302da34e8fc90747d66619334fcfda4e7b8998456fe3619ab860 fix-execinfo.patch
c9e0b05640d7d0e6053b8dd4735664d761a7d381c5b5cbda059fb7b38ab28531c014b6d38f58a0e1f7171a43d62f04d8ecbb7b6b008d0ad30017228ec7e6601a fix-includes.patch"