aboutsummaryrefslogtreecommitdiffstats
path: root/community/libreoffice
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2016-12-26 12:46:50 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2016-12-26 14:17:36 +0000
commitd4cb3b18ec7b9eafc5f92268372beb3d0628eb72 (patch)
tree7843c993261479358f69df1ff6c6fdf16fedfa59 /community/libreoffice
parentf18a0b9a55cf09f187aac374f9070abfde378181 (diff)
downloadaports-d4cb3b18ec7b9eafc5f92268372beb3d0628eb72.tar.bz2
aports-d4cb3b18ec7b9eafc5f92268372beb3d0628eb72.tar.xz
community/libreoffice: buildfix for icu-58
Diffstat (limited to 'community/libreoffice')
-rw-r--r--community/libreoffice/0010-icu-58.patch42
-rw-r--r--community/libreoffice/APKBUILD12
2 files changed, 50 insertions, 4 deletions
diff --git a/community/libreoffice/0010-icu-58.patch b/community/libreoffice/0010-icu-58.patch
new file mode 100644
index 0000000000..362357017c
--- /dev/null
+++ b/community/libreoffice/0010-icu-58.patch
@@ -0,0 +1,42 @@
+Minimal exceprt from upstream fix only to unbreak build
+
+https://cgit.freedesktop.org/libreoffice/core/commit/?id=3e42714c76b1347babfdea0564009d8d82a83af4
+
+--- a/i18npool/source/breakiterator/breakiterator_unicode.cxx.orig 2016-05-04 21:28:24 UTC
++++ b/i18npool/source/breakiterator/breakiterator_unicode.cxx
+@@ -64,10 +64,13 @@ BreakIterator_Unicode::~BreakIterator_Un
+ class OOoRuleBasedBreakIterator : public RuleBasedBreakIterator
+ {
+ public:
++#if (U_ICU_VERSION_MAJOR_NUM < 58)
++ // RuleBasedBreakIterator::setBreakType() is private as of ICU 58.
+ inline void publicSetBreakType(int32_t type)
+ {
+ setBreakType(type);
+ };
++#endif
+ OOoRuleBasedBreakIterator(UDataMemory* image,
+ UErrorCode &status)
+ : RuleBasedBreakIterator(image, status)
+@@ -143,12 +146,21 @@ void SAL_CALL BreakIterator_Unicode::loa
+ }
+ }
+ if (rbi) {
++#if (U_ICU_VERSION_MAJOR_NUM < 58)
++ // ICU 58 made RuleBasedBreakIterator::setBreakType() private
++ // instead of protected, so the old workaround of
++ // https://ssl.icu-project.org/trac/ticket/5498
++ // doesn't work anymore. However, they also claim to have fixed
++ // the cause that an initial fBreakType==-1 would lead to an
++ // endless loop under some circumstances.
++ // Let's see ...
+ switch (rBreakType) {
+ case LOAD_CHARACTER_BREAKITERATOR: rbi->publicSetBreakType(UBRK_CHARACTER); break;
+ case LOAD_WORD_BREAKITERATOR: rbi->publicSetBreakType(UBRK_WORD); break;
+ case LOAD_SENTENCE_BREAKITERATOR: rbi->publicSetBreakType(UBRK_SENTENCE); break;
+ case LOAD_LINE_BREAKITERATOR: rbi->publicSetBreakType(UBRK_LINE); break;
+ }
++#endif
+ icuBI->aBreakIterator = rbi;
+ }
+ }
diff --git a/community/libreoffice/APKBUILD b/community/libreoffice/APKBUILD
index cc812433fc..69d7d7806b 100644
--- a/community/libreoffice/APKBUILD
+++ b/community/libreoffice/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer:
pkgname=libreoffice
pkgver=5.2.3.3
-pkgrel=2
+pkgrel=3
pkgdesc="LibreOffice - Meta package for the full office suite"
url="http://www.libreoffice.org/"
arch="all"
@@ -38,6 +38,7 @@ source="http://download.documentfoundation.org/libreoffice/src/${_v}/libreoffice
linux-musl.patch
fix-execinfo.patch
fix-includes.patch
+ 0010-icu-58.patch
"
languages=""
@@ -323,18 +324,21 @@ md5sums="6177d8be5ca358929277a19292cae36d libreoffice-5.2.3.3.tar.xz
ce12af00283eb90d9281956524250d6e ce12af00283eb90d9281956524250d6e-xmlsec1-1.2.20.tar.gz
bfde50b1b04c715cd172be03a204521f linux-musl.patch
1cff63a520d1b037edddf1b4de4799dc fix-execinfo.patch
-c6fc4d38ef1bab69f3570a0d087b4c52 fix-includes.patch"
+c6fc4d38ef1bab69f3570a0d087b4c52 fix-includes.patch
+ef0fced535314a39b836b641e593dc6c 0010-icu-58.patch"
sha256sums="a8f1365d166bf24ac4b97ed8466f46cca29cf72e7e992bb84d24c3dc8e1c32c1 libreoffice-5.2.3.3.tar.xz
c40ac3a1381c3c6e8281df1b7d9eb5f99db794a32012e45762b0847b520529a5 libreoffice-dictionaries-5.2.3.3.tar.xz
8401e51c4b91cd47f103ba09519f0b5b9213561b7d6296ff5bdc2d1622950a48 libreoffice-translations-5.2.3.3.tar.xz
3221593ca50f362b546a0888a1431ad24be1470f96b2469c0e0df5e1c55e7305 ce12af00283eb90d9281956524250d6e-xmlsec1-1.2.20.tar.gz
fd0778cfd18b034a415a8966f7a3d8437c3f2ba1c6cfde8220ba663261b9c67f linux-musl.patch
7171dfa651a7ee81b4e13a9fd9131428d9a65af138cac4cb428ae6c3e4bcb1f3 fix-execinfo.patch
-51052d983eeea85d8d71385e4eeda61b6a8746854fe046b9a91e12c013d9ed89 fix-includes.patch"
+51052d983eeea85d8d71385e4eeda61b6a8746854fe046b9a91e12c013d9ed89 fix-includes.patch
+c3ff14bd23804b4fc3817fb6371eb7c56dcb9dcaddd2cb43ecbb7ccf6a801597 0010-icu-58.patch"
sha512sums="8628a820ad620ca946457adf0b0ed9741f13c67aa061761d04b743340d13ef498f23e75e6183206b34ce7154b1ec3096f8afcb69b2ab02e17c6ef00155e1b084 libreoffice-5.2.3.3.tar.xz
f618f88f45a9c9c526029030922427f9bfa73e35d452fdd1821690ba361f8656106556d94427f328066905f0ac7dcd761f384eba7feaf61a00e4828d5b97de98 libreoffice-dictionaries-5.2.3.3.tar.xz
939246f7c96799a0b5a4f6496b68ba9b941b6ef6691418a887cabaffd7fc19408b5a2d8b12b850c6a02c838ffd29190e63a50f23cf168602bb51b1b10e0a427c libreoffice-translations-5.2.3.3.tar.xz
2f8d473916abf9822367edbe857fc2e12dc9858d12e790d689d787e439904bd6a452bf631043aa66e7502457ab0815a473657f58fca17a213e2490f5655e5ae5 ce12af00283eb90d9281956524250d6e-xmlsec1-1.2.20.tar.gz
6abfd9c6cf1917e9ee89695086013c94f5ec68f9732ad60faeeaabe6f3765f5ff19df575a3ef0098d6dd6ba3c76369cec871770396f5cd84829031c3e38485a8 linux-musl.patch
567123f990c4a47c2e4cebf99f3486150740015e647ca2b2521e606f3350fc55ceda6c7ac031302da34e8fc90747d66619334fcfda4e7b8998456fe3619ab860 fix-execinfo.patch
-c9e0b05640d7d0e6053b8dd4735664d761a7d381c5b5cbda059fb7b38ab28531c014b6d38f58a0e1f7171a43d62f04d8ecbb7b6b008d0ad30017228ec7e6601a fix-includes.patch"
+c9e0b05640d7d0e6053b8dd4735664d761a7d381c5b5cbda059fb7b38ab28531c014b6d38f58a0e1f7171a43d62f04d8ecbb7b6b008d0ad30017228ec7e6601a fix-includes.patch
+787eacb819935018d5230f3bceb7697bdb937ac776c88e4b5fece26dcb1069f338e2e1f1d4468df41facc3a2ec62e464f1ba14429aa2b5b509debf9146099ad2 0010-icu-58.patch"