aboutsummaryrefslogtreecommitdiffstats
path: root/community/libreswan
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2017-08-14 12:01:10 +0000
committerTimo Teräs <timo.teras@iki.fi>2017-08-14 12:01:10 +0000
commit85807c16d3a444643a18b5f24610d88ebfdb1db7 (patch)
tree07e60c72b42240f34c3614971a32bde599a57b1b /community/libreswan
parentcf50c7124965a0311c14713750f0e99310b7e493 (diff)
downloadaports-85807c16d3a444643a18b5f24610d88ebfdb1db7.tar.bz2
aports-85807c16d3a444643a18b5f24610d88ebfdb1db7.tar.xz
community/libreswan: fix HOST_NAME_MAX
fix build failure on ppc64le
Diffstat (limited to 'community/libreswan')
-rw-r--r--community/libreswan/APKBUILD7
-rw-r--r--community/libreswan/fix-host-name-max.patch11
2 files changed, 16 insertions, 2 deletions
diff --git a/community/libreswan/APKBUILD b/community/libreswan/APKBUILD
index 17fa27613c..01e1c33b6c 100644
--- a/community/libreswan/APKBUILD
+++ b/community/libreswan/APKBUILD
@@ -12,7 +12,9 @@ depends_dev="gmp-dev linux-pam-dev nss-dev unbound-dev libcap-ng-dev curl-dev ns
provides="openswan"
makedepends="$depends_dev bison flex coreutils bash xmlto"
subpackages="$pkgname-doc"
-source="https://download.libreswan.org/libreswan-$pkgver.tar.gz"
+source="https://download.libreswan.org/libreswan-$pkgver.tar.gz
+ fix-host-name-max.patch
+ "
builddir="$srcdir"/$pkgname-$pkgver
@@ -38,4 +40,5 @@ package() {
install
}
-sha512sums="f1ef002b3e0869920edfebfc8efd73d9a9f84f64a77ad4832f46b12dfdd3c31cdf48c1473522b63f155058592c46af05995756af5440ca3e9c0fa5207436e0fc libreswan-3.21.tar.gz"
+sha512sums="f1ef002b3e0869920edfebfc8efd73d9a9f84f64a77ad4832f46b12dfdd3c31cdf48c1473522b63f155058592c46af05995756af5440ca3e9c0fa5207436e0fc libreswan-3.21.tar.gz
+53a46148e8bcdff89acecd03b38d07133fae2c95fb76b1c9f28e5a597d9468a071d41e637b7d84def8d0d61823d97b9b0f29daca4e31bfabc8babeb9c9082d42 fix-host-name-max.patch"
diff --git a/community/libreswan/fix-host-name-max.patch b/community/libreswan/fix-host-name-max.patch
new file mode 100644
index 0000000000..13d0fd0d2c
--- /dev/null
+++ b/community/libreswan/fix-host-name-max.patch
@@ -0,0 +1,11 @@
+diff -ru libreswan-3.21.orig/programs/pluto/ikev2_ipseckey.c libreswan-3.21/programs/pluto/ikev2_ipseckey.c
+--- libreswan-3.21.orig/programs/pluto/ikev2_ipseckey.c 2017-08-09 20:47:34.000000000 +0000
++++ libreswan-3.21/programs/pluto/ikev2_ipseckey.c 2017-08-14 12:00:26.380840562 +0000
+@@ -23,6 +23,7 @@
+ #include <stddef.h>
+ #include <stdlib.h>
+ #include <unistd.h>
++#include <limits.h>
+ #include <errno.h>
+ #include <arpa/inet.h> /* for inet_ntop */
+ #include <arpa/nameser.h>