aboutsummaryrefslogtreecommitdiffstats
path: root/community/libreswan
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2016-10-10 20:58:07 +0300
committerTimo Teräs <timo.teras@iki.fi>2016-10-10 20:58:41 +0300
commitdb00a3ff619a59dac787fcb017904212bc18f9a7 (patch)
tree1d2712d4229c92778d7c95c2e6b72b449db2b886 /community/libreswan
parent0850e331924938016912ac3360858519688de56d (diff)
downloadaports-db00a3ff619a59dac787fcb017904212bc18f9a7.tar.bz2
aports-db00a3ff619a59dac787fcb017904212bc18f9a7.tar.xz
community/libreswan: revive from unmaintained, upgrade to 3.18
Diffstat (limited to 'community/libreswan')
-rw-r--r--community/libreswan/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/community/libreswan/APKBUILD b/community/libreswan/APKBUILD
new file mode 100644
index 0000000000..8a613ee4de
--- /dev/null
+++ b/community/libreswan/APKBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+
+pkgname=libreswan
+pkgver=3.18
+pkgrel=0
+pkgdesc="IPsec implementation for Linux"
+url="https://libreswan.org"
+arch="all"
+license="GPLv2"
+depends="nss-tools iproute2"
+depends_dev="gmp-dev linux-pam-dev nss-dev unbound-dev libcap-ng-dev curl-dev nspr-dev bsd-compat-headers"
+provides="openswan"
+makedepends="$depends_dev bison flex coreutils bash xmlto"
+subpackages="$pkgname-doc"
+source="https://download.libreswan.org/libreswan-$pkgver.tar.gz"
+
+builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ make WERROR_CFLAGS="" \
+ INC_RCDEFAULT=/etc/init.d \
+ INC_USRLOCAL=/usr \
+ FINALBINDIR=/usr/libexec/ipsec \
+ FINALLIBEXECDIR=/usr/libexec/ipsec \
+ programs || return 1
+}
+
+package() {
+ cd "$builddir"
+ make INC_MANDIR=share/man \
+ INC_RCDEFAULT=/etc/init.d \
+ INC_USRLOCAL=/usr \
+ DESTDIR="$pkgdir" \
+ INSTCONFFLAGS=-m644 \
+ FINALBINDIR=/usr/libexec/ipsec \
+ FINALLIBEXECDIR=/usr/libexec/ipsec \
+ install || return 1
+}
+md5sums="600c40e0d94c61408c7b4948971d78f4 libreswan-3.18.tar.gz"
+sha256sums="2ff61178913287567ed2736287df47e7f9a822ddcded967f3af5f03e95b5f17d libreswan-3.18.tar.gz"
+sha512sums="dfc831ae82814a26cac2eb7c8bef4385d8aebb1e62c63f31e0997d49fc6bbcc6e4e2bcd0e07d5c0c1347e5eaca5f6eb1fba98395bc882ab0fddb804a524b57f8 libreswan-3.18.tar.gz"