aboutsummaryrefslogtreecommitdiffstats
path: root/community/libzip/APKBUILD
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-23 17:50:34 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-23 17:54:18 +0000
commit0e83abc9a09e573eca48ee2397e971bd7738c53c (patch)
treecd16af58756742b9e633fc99d4792207ca44e391 /community/libzip/APKBUILD
parent62750af0fedc04e43d6393aecd7d3d440a2ea2c5 (diff)
downloadaports-0e83abc9a09e573eca48ee2397e971bd7738c53c.tar.bz2
aports-0e83abc9a09e573eca48ee2397e971bd7738c53c.tar.xz
community/libzip: modernize and add check
Diffstat (limited to 'community/libzip/APKBUILD')
-rw-r--r--community/libzip/APKBUILD19
1 files changed, 11 insertions, 8 deletions
diff --git a/community/libzip/APKBUILD b/community/libzip/APKBUILD
index 85addab28e..b17b7db2e2 100644
--- a/community/libzip/APKBUILD
+++ b/community/libzip/APKBUILD
@@ -3,12 +3,11 @@
# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
pkgname=libzip
pkgver=1.3.0
-pkgrel=0
+pkgrel=1
pkgdesc="A C library for reading, creating, and modifying zip archives"
url="http://www.nih.at/libzip/index.html"
arch="all"
license="BSD"
-depends=
depends_dev="zlib-dev"
makedepends="$depends_dev perl"
subpackages="$pkgname-dev $pkgname-doc $pkgname-tools"
@@ -28,22 +27,26 @@ build() {
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
- --localstatedir=/var \
- || return 1
- make || return 1
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" -j1 install install-man || return 1
- mv "$pkgdir"/usr/lib/libzip/include/* "$pkgdir"/usr/include || return 1
+ make DESTDIR="$pkgdir" -j1 install install-man
+ mv "$pkgdir"/usr/lib/libzip/include/* "$pkgdir"/usr/include
rm -fr "$pkgdir"/usr/lib/libzip
}
tools() {
pkgdesc="$pkgname cmp and merge tools"
install -d "$subpkgdir"/usr
- mv "$pkgdir"/usr/bin "$subpkgdir"/usr || return 1
+ mv "$pkgdir"/usr/bin "$subpkgdir"/usr
}
sha512sums="8cffbcd27b9e6c9676c5224c5784190bff881ac690ce0f58702b17c99ee6d1c14eda266298841f896a02233d2eb5f4147d5c8b4ad55d36c384eaa560fd96ff89 libzip-1.3.0.tar.gz"