aboutsummaryrefslogtreecommitdiffstats
path: root/community/llvm-libunwind
diff options
context:
space:
mode:
authorxentec <xentec@aix0.eu>2017-10-23 18:29:20 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-11-14 18:42:44 +0100
commitd890bf664455f53f2560b6207409cfa867cf3b40 (patch)
tree021a9974bb7f6e821a19c19e331e4c3cd9d83661 /community/llvm-libunwind
parentbc087384329e97ff13060f91e4cb3290492493ee (diff)
downloadaports-d890bf664455f53f2560b6207409cfa867cf3b40.tar.bz2
aports-d890bf664455f53f2560b6207409cfa867cf3b40.tar.xz
community/llvm-libunwind: upgrade to 5.0.0
Diffstat (limited to 'community/llvm-libunwind')
-rw-r--r--community/llvm-libunwind/APKBUILD17
-rw-r--r--community/llvm-libunwind/no-exec-stack.patch19
2 files changed, 9 insertions, 27 deletions
diff --git a/community/llvm-libunwind/APKBUILD b/community/llvm-libunwind/APKBUILD
index 4aaeb5d093..0af66f4241 100644
--- a/community/llvm-libunwind/APKBUILD
+++ b/community/llvm-libunwind/APKBUILD
@@ -1,8 +1,9 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=llvm-libunwind
+# Note: Update together with llvm.
+pkgver=5.0.0
_pkgname=libunwind
-pkgver=4.0.0
_llvmver=${pkgver%%.*}
pkgrel=0
pkgdesc="LLVM version of libunwind library"
@@ -12,31 +13,31 @@ license="BSD"
depends_dev="!libunwind-dev"
makedepends="cmake llvm$_llvmver-dev"
subpackages="$pkgname-dev"
-source="http://www.llvm.org/releases/$pkgver/$_pkgname-$pkgver.src.tar.xz
- no-exec-stack.patch"
+source="https://www.llvm.org/releases/$pkgver/$_pkgname-$pkgver.src.tar.xz"
builddir="$srcdir/$_pkgname-$pkgver.src"
options="!check"
build() {
- cd "$builddir"
+ mkdir -p "$builddir/build"
+ cd "$builddir/build"
- cmake \
+ cmake .. \
-DCMAKE_BUILD_TYPE=MinSizeRel \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_CXX_FLAGS="$CXXFLAGS" \
-DCMAKE_C_FLAGS="$CFLAGS" \
-DLLVM_CONFIG_PATH="/usr/lib/llvm$_llvmver/bin/llvm-config" \
-DLIBUNWIND_HAS_NODEFAULTLIBS_FLAG=OFF
+
make
}
package() {
cd "$builddir"
- make install DESTDIR="$pkgdir"
+ make -C build install DESTDIR="$pkgdir"
mkdir -p "$pkgdir"/usr/include
cp include/*.h "$pkgdir"/usr/include/
}
-sha512sums="c3c934b70830ef5496c9d24c469b702eb4408abd4fe4dd9e0832230b064dc78d23b02ed2a5ce9a099dea76c3d43cbf41d59c6cda189f990d5593c7d3cd5c79dd libunwind-4.0.0.src.tar.xz
-2a61580331a9c8e5f9d4a12a845be187db65434257bb635eb509db43355709de0f17ddd8a589e0c8ee89ed29c0dc1cefd0fd9d11e4a0eb875b14ad4833063d11 no-exec-stack.patch"
+sha512sums="20d54d5342d67425f5e36e9c690f1bb67bc2a3b7184b3ad546b689e510728d7c596f178d4f5186daf7480409ed4e455848b4ad1d9d896370fac1db69885fc793 libunwind-5.0.0.src.tar.xz"
diff --git a/community/llvm-libunwind/no-exec-stack.patch b/community/llvm-libunwind/no-exec-stack.patch
deleted file mode 100644
index 6220e946b3..0000000000
--- a/community/llvm-libunwind/no-exec-stack.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-Remove the gatekeeping to set a non-executable stack for libunwind,
-as we don't define any of these directives but still want it.
-
-diff -Nru a/src/assembly.h b/src/assembly.h
---- a/src/assembly.h 2016-10-23 21:48:47.000000000 +0000
-+++ b/src/assembly.h 2017-05-16 12:38:47.209169931 +0000
-@@ -47,12 +47,7 @@
- #define SYMBOL_IS_FUNC(name) .type name,@function
- #endif
-
--#if defined(__GNU__) || defined(__ANDROID__) || defined(__FreeBSD__) || \
-- defined(__Fuchsia__)
- #define NO_EXEC_STACK_DIRECTIVE .section .note.GNU-stack,"",%progbits
--#else
--#define NO_EXEC_STACK_DIRECTIVE
--#endif
-
- #else
-