aboutsummaryrefslogtreecommitdiffstats
path: root/community/lmdb/lmdb_make.patch
diff options
context:
space:
mode:
authorOlivier Mauras <olivier@mauras.ch>2016-08-18 22:49:57 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-22 22:47:06 +0200
commitffea920168e4bbf800150e4cd9d5a6205d978625 (patch)
tree3af67ef573287d6b1b72562e29b8068dff442303 /community/lmdb/lmdb_make.patch
parente0e276e6cfc607b5315e04b78eed6888290910d6 (diff)
downloadaports-ffea920168e4bbf800150e4cd9d5a6205d978625.tar.bz2
aports-ffea920168e4bbf800150e4cd9d5a6205d978625.tar.xz
testing/[various]: move to community
Diffstat (limited to 'community/lmdb/lmdb_make.patch')
-rw-r--r--community/lmdb/lmdb_make.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/community/lmdb/lmdb_make.patch b/community/lmdb/lmdb_make.patch
new file mode 100644
index 0000000000..b5b2bafa4e
--- /dev/null
+++ b/community/lmdb/lmdb_make.patch
@@ -0,0 +1,28 @@
+diff --git a/Makefile b/Makefile
+index dbb5d69..149bdbf 100644
+--- a/Makefile
++++ b/Makefile
+@@ -23,11 +23,11 @@ AR = ar
+ W = -W -Wall -Wno-unused-parameter -Wbad-function-cast -Wuninitialized
+ THREADS = -pthread
+ OPT = -O2 -g
+-CFLAGS = $(THREADS) $(OPT) $(W) $(XCFLAGS)
++CFLAGS = $(THREADS) $(OPT) $(W) $(XCFLAGS) -fPIC
+ LDLIBS =
+ SOLIBS =
+-prefix = /usr/local
+-mandir = $(prefix)/man
++prefix = /usr
++mandir = $(prefix)/share/man
+
+ ########################################################################
+
+@@ -42,7 +42,7 @@ install: $(ILIBS) $(IPROGS) $(IHDRS)
+ mkdir -p $(DESTDIR)$(prefix)/bin
+ mkdir -p $(DESTDIR)$(prefix)/lib
+ mkdir -p $(DESTDIR)$(prefix)/include
+- mkdir -p $(DESTDIR)$(prefix)/man/man1
++ mkdir -p $(DESTDIR)$(mandir)/man1
+ for f in $(IPROGS); do cp $$f $(DESTDIR)$(prefix)/bin; done
+ for f in $(ILIBS); do cp $$f $(DESTDIR)$(prefix)/lib; done
+ for f in $(IHDRS); do cp $$f $(DESTDIR)$(prefix)/include; done