aboutsummaryrefslogtreecommitdiffstats
path: root/community/lrzip
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2018-03-31 10:40:25 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2018-03-31 10:41:00 +0000
commit2cb3f040e112a78e246054b2e159e2ad0adc6677 (patch)
tree3afbcb891a60adda4375afd9320ecf8335121d18 /community/lrzip
parent1d6ab7d01b60c9f7cd43482ad67acc6bfeea2705 (diff)
downloadaports-2cb3f040e112a78e246054b2e159e2ad0adc6677.tar.bz2
aports-2cb3f040e112a78e246054b2e159e2ad0adc6677.tar.xz
testing/lrzip: move to community
Diffstat (limited to 'community/lrzip')
-rw-r--r--community/lrzip/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/community/lrzip/APKBUILD b/community/lrzip/APKBUILD
new file mode 100644
index 0000000000..5f27199854
--- /dev/null
+++ b/community/lrzip/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Roberto Oliveira <robertoguimaraes8@gmail.com>
+# Maintainer: Roberto Oliveira <robertoguimaraes8@gmail.com>
+pkgname=lrzip
+pkgver=0.631
+pkgrel=0
+pkgdesc="A compression utility that excels at compressing large files"
+url="https://github.com/ckolivas/lrzip"
+arch="all"
+license="GPL-2.0"
+depends="bash"
+makedepends="autoconf automake libtool zlib-dev bzip2-dev lzo-dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/ckolivas/lrzip/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ default_prepare
+ cd "$builddir"
+ ./autogen.sh
+}
+
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make install DESTDIR="$pkgdir"
+}
+
+sha512sums="acaedf406455e1a491cb6575585f2af0170e332838707b9e0e7c037b22994a30c8c514ef4b91bc6dde8369835e4e2ae51ebb9431263ca4f35111be2daabd5aef lrzip-0.631.tar.gz"