aboutsummaryrefslogtreecommitdiffstats
path: root/community/lua-dromozoa-utf8
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-05-24 02:56:34 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-05-24 02:51:31 +0200
commit88be28287b64e5d7b093a32c9d1d2aab0432f235 (patch)
tree95c6cb73f6fc9db1d465e02aaf5e045de26ecd92 /community/lua-dromozoa-utf8
parent8b071925b611794515f0a7615c0b1909c05241f2 (diff)
downloadaports-88be28287b64e5d7b093a32c9d1d2aab0432f235.tar.bz2
aports-88be28287b64e5d7b093a32c9d1d2aab0432f235.tar.xz
community/lua-dromozoa-utf8: downgrade to 1.11
Upstream removed release 2.0 and continue with 1.x... >_<
Diffstat (limited to 'community/lua-dromozoa-utf8')
-rw-r--r--community/lua-dromozoa-utf8/APKBUILD6
-rw-r--r--community/lua-dromozoa-utf8/test.sh.patch18
2 files changed, 12 insertions, 12 deletions
diff --git a/community/lua-dromozoa-utf8/APKBUILD b/community/lua-dromozoa-utf8/APKBUILD
index 50cd3ead10..8fd180cffa 100644
--- a/community/lua-dromozoa-utf8/APKBUILD
+++ b/community/lua-dromozoa-utf8/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=lua-dromozoa-utf8
_pkgname=dromozoa-utf8
-pkgver=2.0
+pkgver=1.11
pkgrel=0
pkgdesc="Lua 5.3 compatible pure-Lua UTF-8 implementation"
url="https://github.com/dromozoa/dromozoa-utf8/"
@@ -56,5 +56,5 @@ _subpackage() {
echo 'rock_manifest = {}' > "$rockdir"/rock_manifest
}
-sha512sums="6899fee64276dc3732dad4353f3d9186acbe46841f8867bc3332005fc386f0d7de24786cd701edf4f3025e77d6bffa3c72070af82526eb85f9d7e20d9cc6fb28 lua-dromozoa-utf8-2.0.tar.gz
-de29a3b7a1067b8181b2a40464a097d4474e474ff6e3f6295bce8bc2bd8a0bee29fae1f34ae300a83a60db91915af96bb464141e58d7bc67a970391399703140 test.sh.patch"
+sha512sums="794b3d7728776e4ffb2d57e0a0e9068fdcb3c34ccdaa3e1be45413d20ab8deb6d3e77fc067398e589dfa463976dfc08c8b314e8bf652a87e95c5b197f75c3140 lua-dromozoa-utf8-1.11.tar.gz
+5b24a1aef26a934aea9e116af857a0323d5e0b639f2d5ff66b6cc5310bf9c2315855f3034e3c5e40bda0e91f970ba90ebdd97c6eb08b2f6683b131fe5ba2ecb5 test.sh.patch"
diff --git a/community/lua-dromozoa-utf8/test.sh.patch b/community/lua-dromozoa-utf8/test.sh.patch
index 7632adf739..ea0ac1c88d 100644
--- a/community/lua-dromozoa-utf8/test.sh.patch
+++ b/community/lua-dromozoa-utf8/test.sh.patch
@@ -3,15 +3,15 @@ Don't overwhelm console with test output...
--- a/test.sh
+++ b/test.sh
@@ -24,7 +24,11 @@
-
- for i in test/test*.lua
do
-- "$lua" "$i"
-+ "$lua" "$i" > "${i%.lua}.out" 2>&1 || {
-+ echo "Tests failed, printing last 30 lines of the output..."
-+ tail -n 30 "${i%.lua}.out"
-+ exit 1
-+ }
+ case X$# in
+ X0) lua "$i";;
+- *) "$@" "$i";;
++ *) "$@" "$i" > "${i%.lua}.out" 2>&1 || {
++ echo "Tests failed, printing last 30 lines of the output..."
++ tail -n 30 "${i%.lua}.out"
++ exit 1
++ };;
+ esac
done
- mkdir -p out