aboutsummaryrefslogtreecommitdiffstats
path: root/community/lua-fun
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-03-30 12:11:58 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-03-30 12:31:13 +0200
commit1a7d38e19717a7711816789c341b9265e83ff758 (patch)
treeae287e9c8a0ba917fe93ce711abc42c54f467349 /community/lua-fun
parent499f771ef43c5b3a22a85ddf985a54a0f3f008c0 (diff)
downloadaports-1a7d38e19717a7711816789c341b9265e83ff758.tar.bz2
aports-1a7d38e19717a7711816789c341b9265e83ff758.tar.xz
community/lua-fun: clean the mess with luajit condition
Diffstat (limited to 'community/lua-fun')
-rw-r--r--community/lua-fun/APKBUILD24
1 files changed, 13 insertions, 11 deletions
diff --git a/community/lua-fun/APKBUILD b/community/lua-fun/APKBUILD
index e5fea9b14b..6865f0c2cf 100644
--- a/community/lua-fun/APKBUILD
+++ b/community/lua-fun/APKBUILD
@@ -3,17 +3,23 @@
pkgname=lua-fun
_pkgname=luafun
pkgver=0.1.3
-pkgrel=4
+pkgrel=5
pkgdesc="Functional programming library"
url="http://rtsisyk.github.io/luafun/"
arch="noarch"
license="MIT"
depends=""
makedepends=""
-[ "$CARCH" == "s390x" ] && [ "$CARCH" == "ppc64le" ] && checkdepends="" || checkdepends="luajit"
+checkdepends=""
source="$pkgname-$pkgver.tar.gz::https://github.com/rtsisyk/$_pkgname/archive/$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
+# luajit is not available for selected arches
+case "$CARCH" in
+ ppc64le | s390x) _luajit="";;
+ *) checkdepends="$checkdepends luajit" _luajit="jit";;
+esac
+
_luaversions="5.1 5.2 5.3"
for _v in $_luaversions; do
makedepends="$makedepends lua$_v-dev"
@@ -22,15 +28,11 @@ done
check() {
cd "$builddir"
- # luajit not avail for selected arches
- if printf "$checkdepends\n" | grep -q "luajit"; then
- if [ "$CARCH" != "ppc64le" ] && [ "$CARCH" != "s390x" ]; then
- local lver; for lver in $_luaversions jit; do
- msg "Testing on Lua $lver"
- lua$lver tests/runtest tests/*.lua || return 1
- done
- fi
- fi
+
+ local lver; for lver in $_luaversions $_luajit; do
+ msg "Testing on Lua $lver"
+ lua$lver tests/runtest tests/*.lua || return 1
+ done
}
package() {