aboutsummaryrefslogtreecommitdiffstats
path: root/community/lua-fun
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-03-12 22:18:01 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-03-12 22:21:23 +0100
commit1da0063c9ad216656ed395c04b7e0ee8c182482b (patch)
tree1ceea5bf1dd6556f61e8af55f981cd83fadefce6 /community/lua-fun
parentf3fa5c6db3524749a9c3dafb1bfcec29b0c827dc (diff)
downloadaports-1da0063c9ad216656ed395c04b7e0ee8c182482b.tar.bz2
aports-1da0063c9ad216656ed395c04b7e0ee8c182482b.tar.xz
community/lua-fun: add check function
Diffstat (limited to 'community/lua-fun')
-rw-r--r--community/lua-fun/APKBUILD12
1 files changed, 11 insertions, 1 deletions
diff --git a/community/lua-fun/APKBUILD b/community/lua-fun/APKBUILD
index 3154a2777a..9ef7b283ee 100644
--- a/community/lua-fun/APKBUILD
+++ b/community/lua-fun/APKBUILD
@@ -3,13 +3,14 @@
pkgname=lua-fun
_pkgname=luafun
pkgver=0.1.3
-pkgrel=1
+pkgrel=2
pkgdesc="Functional programming library"
url="http://rtsisyk.github.io/luafun/"
arch="noarch"
license="MIT"
depends=""
makedepends=""
+checkdepends="luajit"
source="$pkgname-$pkgver.tar.gz::https://github.com/rtsisyk/$_pkgname/archive/$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
@@ -19,6 +20,15 @@ for _v in $_luaversions; do
subpackages="$subpackages lua$_v-${pkgname#lua-}:_subpackage"
done
+check() {
+ cd "$builddir"
+
+ local lver; for lver in $_luaversions jit; do
+ msg "Testing on Lua $lver"
+ lua$lver tests/runtest tests/*.lua || return 1
+ done
+}
+
package() {
mkdir -p "$pkgdir"
}