aboutsummaryrefslogtreecommitdiffstats
path: root/community/lua-hiredis/0003-lua-5-2-compatibility.patch
diff options
context:
space:
mode:
authorNathan Angelacos <nangel@alpinelinux.org>2017-07-31 19:54:39 -0400
committerNatanael Copa <ncopa@alpinelinux.org>2017-08-03 13:20:16 +0000
commitd68c23c52432fcd21f65090a99d249294d2f05ed (patch)
tree16f62fd1bf781c9d5ca3a08467d9f2546b38b13e /community/lua-hiredis/0003-lua-5-2-compatibility.patch
parent0ba9f6eb5db697becaaae8311450af847f8809a9 (diff)
downloadaports-d68c23c52432fcd21f65090a99d249294d2f05ed.tar.bz2
aports-d68c23c52432fcd21f65090a99d249294d2f05ed.tar.xz
community/lua-hiredis
APKBUILD: hiredis.so now loads correctly 0003-: spell compatibility correctly 0004-: add backward compatibility define for luaL_checkint for Lua 5.3+
Diffstat (limited to 'community/lua-hiredis/0003-lua-5-2-compatibility.patch')
-rw-r--r--community/lua-hiredis/0003-lua-5-2-compatibility.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/community/lua-hiredis/0003-lua-5-2-compatibility.patch b/community/lua-hiredis/0003-lua-5-2-compatibility.patch
new file mode 100644
index 0000000000..8ca7458d00
--- /dev/null
+++ b/community/lua-hiredis/0003-lua-5-2-compatibility.patch
@@ -0,0 +1,36 @@
+diff --git a/AUTHORS b/AUTHORS
+index bd5ee8a..f10d214 100644
+--- a/AUTHORS
++++ b/AUTHORS
+@@ -8,3 +8,4 @@ lua-hiredis bindings contributors:
+
+ Stein Ivar Berghei <stein-ivar@berghei.no>
+ Peter Melnichenko <petjamelnik@yandex.ru>
++Andey Kunitsyn <blackicebox@gmail.com>
+diff --git a/src/lua-hiredis.c b/src/lua-hiredis.c
+index 3dfafc1..079cbd9 100644
+--- a/src/lua-hiredis.c
++++ b/src/lua-hiredis.c
+@@ -34,6 +34,22 @@ extern "C" {
+
+ #define LUAHIREDIS_KEY_NIL "NIL"
+
++#if LUA_VERSION_NUM >= 502
++static void luaL_register(lua_State * L, const char * name, const luaL_Reg * l)
++{
++ if (name)
++ {
++ lua_newtable(L);
++ luaL_setfuncs(L, l, 0);
++ lua_pushvalue(L,-1);
++ lua_setglobal(L,name);
++ } else
++ {
++ luaL_setfuncs(L,l,0);
++ }
++}
++#endif
++
+ typedef struct luahiredis_Enum
+ {
+ const char * name;