aboutsummaryrefslogtreecommitdiffstats
path: root/community/lua-hiredis/0004-lua-5-3-compatibility.patch
diff options
context:
space:
mode:
authorNathan Angelacos <nangel@alpinelinux.org>2017-07-31 19:54:39 -0400
committerNatanael Copa <ncopa@alpinelinux.org>2017-08-03 13:20:16 +0000
commitd68c23c52432fcd21f65090a99d249294d2f05ed (patch)
tree16f62fd1bf781c9d5ca3a08467d9f2546b38b13e /community/lua-hiredis/0004-lua-5-3-compatibility.patch
parent0ba9f6eb5db697becaaae8311450af847f8809a9 (diff)
downloadaports-d68c23c52432fcd21f65090a99d249294d2f05ed.tar.bz2
aports-d68c23c52432fcd21f65090a99d249294d2f05ed.tar.xz
community/lua-hiredis
APKBUILD: hiredis.so now loads correctly 0003-: spell compatibility correctly 0004-: add backward compatibility define for luaL_checkint for Lua 5.3+
Diffstat (limited to 'community/lua-hiredis/0004-lua-5-3-compatibility.patch')
-rw-r--r--community/lua-hiredis/0004-lua-5-3-compatibility.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/community/lua-hiredis/0004-lua-5-3-compatibility.patch b/community/lua-hiredis/0004-lua-5-3-compatibility.patch
new file mode 100644
index 0000000000..deb89e6f27
--- /dev/null
+++ b/community/lua-hiredis/0004-lua-5-3-compatibility.patch
@@ -0,0 +1,15 @@
+diff --git a/src/lua-hiredis.c b/src/lua-hiredis.c
+index 4a465ce..8c9541b 100644
+--- a/src/lua-hiredis.c
++++ b/src/lua-hiredis.c
+@@ -50,6 +50,10 @@ static void luaL_register(lua_State * L, const char * name, const luaL_Reg * l)
+ }
+ #endif
+
++#ifndef luaL_checkint
++#define luaL_checkint(L, n) ((int)luaL_checkinteger(L,n))
++#endif
++
+ typedef struct luahiredis_Enum
+ {
+ const char * name;